Commit 81aed75e authored by Stefan Brüns's avatar Stefan Brüns
Browse files

Remove some obsolete Qt 5.10/5.11 QT_VERSION_CHECKs

Minimum Qt version set in CMakeLists.txt is 5.11, so the checks are
redundant.
parent 7b9bd6fd
......@@ -154,11 +154,7 @@ bool TextCreator::create(const QString &path, int width, int height, QImage &img
textDocument.setDefaultFont(font);
QTextOption textOption( Qt::AlignTop | Qt::AlignLeft );
#if (QT_VERSION >= QT_VERSION_CHECK(5, 11, 0))
textOption.setTabStopDistance(8 * painter.fontMetrics().horizontalAdvance(QLatin1Char(' ')));
#else
textOption.setTabStop( 8 * painter.fontMetrics().width( ' ' ) );
#endif
textOption.setWrapMode( QTextOption::WrapAtWordBoundaryOrAnywhere );
textDocument.setDefaultTextOption(textOption);
......
......@@ -314,11 +314,7 @@ void ThumbnailProtocol::get(const QUrl &url)
}
// Keep in sync with kdelibs/kio/kio/previewjob.cpp
stream << img.width() << img.height() << quint8(img.format());
#if (QT_VERSION >= QT_VERSION_CHECK(5, 10, 0))
memcpy(shmaddr, img.bits(), img.sizeInBytes());
#else
memcpy(shmaddr, img.bits(), img.byteCount());
#endif
shmdt((char*)shmaddr);
mimeType("application/octet-stream");
data(imgData);
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment