Commit 1018af83 authored by Elvis Angelaccio's avatar Elvis Angelaccio
Browse files

Introduce version number (0.9.70 preparing for 1.0)

parent 802babd5
......@@ -4,6 +4,8 @@ cmake_minimum_required(VERSION 2.8.12)
include(FeatureSummary)
set(PROJECT_VERSION 0.9.70)
set(QT_MIN_VERSION 5.2.0)
set(KF5_MIN_VERSION 5.14.0)
# TODO: we actually need the unreleased 5.3.1
......@@ -21,6 +23,7 @@ include(KDEInstallDirs)
include(KDECMakeSettings)
include(KDECompilerSettings NO_POLICY_SCOPE)
include(ECMQtDeclareLoggingCategory)
include(ECMSetupVersion)
find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS
I18n
......@@ -38,6 +41,10 @@ if(NOT Qt5Test_FOUND)
set(BUILD_TESTING OFF CACHE BOOL "Build the testing tree.")
endif()
ecm_setup_version(${PROJECT_VERSION}
VARIABLE_PREFIX GDRIVE
VERSION_HEADER gdriveversion.h)
add_definitions(-DQT_NO_URL_CAST_FROM_STRING)
add_definitions(-DTRANSLATION_DOMAIN=\"kio5_gdrive\")
......
include_directories(${CMAKE_SOURCE_DIR})
include_directories(${CMAKE_BINARY_DIR})
set(kio_gdrive_SRCS
kio_gdrive.cpp
......
......@@ -20,6 +20,7 @@
#include "kio_gdrive.h"
#include "gdrivedebug.h"
#include "gdrivehelper.h"
#include "gdriveversion.h"
#include <QApplication>
#include <QTemporaryFile>
......@@ -94,7 +95,7 @@ KIOGDrive::KIOGDrive(const QByteArray &protocol, const QByteArray &pool_socket,
{
Q_UNUSED(protocol);
qCDebug(GDRIVE) << "GDrive ready";
qCDebug(GDRIVE) << "KIO GDrive ready: version" << GDRIVE_VERSION_STRING;
}
KIOGDrive::~KIOGDrive()
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment