1. 27 Aug, 2021 2 commits
  2. 22 Aug, 2021 1 commit
  3. 09 Aug, 2021 1 commit
  4. 04 Aug, 2021 2 commits
  5. 27 Jul, 2021 1 commit
  6. 22 Jul, 2021 1 commit
  7. 18 Jul, 2021 1 commit
  8. 16 Jul, 2021 1 commit
  9. 10 Jul, 2021 1 commit
  10. 30 Jun, 2021 2 commits
  11. 28 Jun, 2021 2 commits
    • Adriaan de Groot's avatar
      CMake: handle hunspell-has-no-dictionaries · e9291387
      Adriaan de Groot authored
      If there are **no** dictionaries for hunspell, then
      the AVAILABLE DICTIONARIES line is followed by no
      output (no lines listing dictionaries). Then
      the match fails, so CMAKE_MATCH_1 is empty,
      and substituting it in the REGEX REPLACE command
      triggers a CMake error like this:
      
      CMake Error at cmake/modules/FindHunspell.cmake:54 (string):
        string sub-command REGEX, mode REPLACE needs at least 6 arguments total to
        command.
      
      Quote it, so that at least the empty string is passed
      in when no dictionaries are available.
      e9291387
    • Adriaan de Groot's avatar
      CMake: require CMake 3.5 or later · c6e78aec
      Adriaan de Groot authored
      - Konqueror requires KDE Frameworks 5.71 or later,
      - Frameworks 5.71 required CMake 3.5 or later,
      - so match the versions.
      
      This would be nicer to bump to 3.16, which is what current KF5
      versions require; right now find_package(KF5) prints a warning
      (just a warning) when the consumer requires an older CMake version.
      c6e78aec
  12. 24 Jun, 2021 1 commit
  13. 21 Jun, 2021 1 commit
  14. 20 Jun, 2021 1 commit
  15. 19 Jun, 2021 1 commit
  16. 04 Jun, 2021 1 commit
  17. 01 Jun, 2021 1 commit
  18. 31 May, 2021 2 commits
    • Jonathan Marten's avatar
      Image Gallery: Eliminate 'endl' deprecation warnings with Qt 5.15 · 3ce8e93e
      Jonathan Marten authored
      warning: 'QTextStream& QTextStreamFunctions::endl(QTextStream&)' is deprecated,
      use 'Qt::endl'
      
      Redefining the symbol, so as to remain compatible with all Qt versions
      (Qt::endl was introduced in Qt 5.14).  'endl' is not needed at the end
      of qDebug() output, so it is simply removed.
      3ce8e93e
    • Jonathan Marten's avatar
      FSView: Eliminate 'endl' deprecation warnings with Qt 5.15 · 070bccaf
      Jonathan Marten authored
      warning: 'QTextStream& QTextStreamFunctions::endl(QTextStream&)' is deprecated,
      use 'Qt::endl'
      
      Compatible with all Qt versions.  'endl' is not needed at the end of
      qDebug() output, so it is simply removed.  The debug statements are not
      normally compiled anyway.
      070bccaf
  19. 30 May, 2021 1 commit
  20. 29 May, 2021 1 commit
  21. 17 May, 2021 1 commit
  22. 16 May, 2021 2 commits
  23. 13 May, 2021 1 commit
    • Stefano Crocco's avatar
      Refactor ClientApp::createNewWindow · 7e9aed1c
      Stefano Crocco authored and David Faure's avatar David Faure committed
      I refactored the Refactor ClientApp::createNewWindow function to remove the goto. I split the function in four parts:
      
      * parseBrowserApplicationString which takes the BrowserApplication string and parses it to determine if it's a command or a service, whether it calls kfmclient itself and to create the command line
      * launchExternalBrowserCommand which launches the external browser if it's specified as a command
      * launchExternalBrowserService which launches the external browser if it's specified as a service
      * createNewWindow itself which uses the above three functions.
      7e9aed1c
  24. 10 May, 2021 1 commit
  25. 03 May, 2021 2 commits
  26. 02 May, 2021 1 commit
  27. 28 Apr, 2021 1 commit
  28. 24 Apr, 2021 1 commit
  29. 23 Apr, 2021 1 commit
  30. 21 Apr, 2021 1 commit
  31. 18 Apr, 2021 1 commit
  32. 11 Apr, 2021 2 commits