Commit eaf1d72a authored by Laurent Montel's avatar Laurent Montel 😁
Browse files

Modernize it

parent 21c407ee
......@@ -6,19 +6,22 @@ set(KDE_APPLICATIONS_VERSION_MAJOR "20")
set(KDE_APPLICATIONS_VERSION_MINOR "03")
set(KDE_APPLICATIONS_VERSION_MICRO "70")
set(kwalletsignon_VERSION "${KDE_APPLICATIONS_VERSION_MAJOR}.${KDE_APPLICATIONS_VERSION_MINOR}.${KDE_APPLICATIONS_VERSION_MICRO}")
set(KF5_MIN_VERSION "5.18.0")
set(QT_REQUIRED_VERSION "5.6.0")
find_package(ECM 5.18.0 REQUIRED NO_MODULE)
find_package(ECM ${KF5_MIN_VERSION} REQUIRED NO_MODULE)
set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules)
find_package(Qt5 5.6.0 CONFIG REQUIRED Core)
find_package(Qt5 ${QT_REQUIRED_VERSION} CONFIG REQUIRED Core)
include(KDEInstallDirs)
include(KDECMakeSettings)
include(FeatureSummary)
include(KDEFrameworkCompilerSettings NO_POLICY_SCOPE)
find_package(KF5 5.18.0 REQUIRED Wallet)
find_package(KF5 ${KF5_MIN_VERSION} REQUIRED Wallet)
find_package(SignOnExtension REQUIRED)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment