Commit d18ba909 authored by Christophe Giboudeaux's avatar Christophe Giboudeaux
Browse files

Fix the akonadi-calendar dependencies

Summary: Add the missing link targets and remove the unneeded dependencies.

Reviewers: mlaurent

Reviewed By: mlaurent

Subscribers: kde-pim

Tags: #kde_pim

Differential Revision: https://phabricator.kde.org/D21207
parent 0940b804
......@@ -42,14 +42,15 @@ if(BUILD_TESTING)
endif()
########### Find packages ###########
find_package(KF5I18n ${KF5_MIN_VERSION} CONFIG REQUIRED)
find_package(KF5WidgetsAddons ${KF5_MIN_VERSION} CONFIG REQUIRED)
find_package(KF5XmlGui ${KF5_MIN_VERSION} CONFIG REQUIRED)
find_package(KF5KIO ${KF5_MIN_VERSION} CONFIG REQUIRED)
find_package(KF5Wallet ${KF5_MIN_VERSION} CONFIG REQUIRED)
find_package(KF5Codecs ${KF5_MIN_VERSION} CONFIG REQUIRED)
find_package(KF5IconThemes ${KF5_MIN_VERSION} CONFIG REQUIRED)
find_package(KF5DBusAddons ${KF5_MIN_VERSION} CONFIG REQUIRED)
find_package(KF5MailTransportAkonadi ${MAILTRANSPORT_LIB_VERSION} CONFIG REQUIRED)
find_package(KF5Contacts ${KCONTACTS_LIB_VERSION} CONFIG REQUIRED)
find_package(KF5IdentityManagement ${IDENTITYMANAGEMENT_LIB_VERSION} CONFIG REQUIRED)
find_package(KF5CalendarCore ${CALENDARCORE_LIB_VERSION} CONFIG REQUIRED)
find_package(KF5CalendarUtils ${CALENDARUTILS_LIB_VERSION} CONFIG REQUIRED)
......
......@@ -2,6 +2,8 @@
include(CMakeFindDependencyMacro)
find_dependency(KF5Akonadi "@AKONADI_LIB_VERSION@")
find_dependency(KF5CalendarCore "@CALENDARCORE_LIB_VERSION@")
find_dependency(KF5AkonadiContact "@AKONADICONTACT_LIB_VERSION@")
find_dependency(KF5I18n "@KF5_MIN_VERSION@")
find_dependency(KF5WidgetsAddons "@KF5_MIN_VERSION@")
include("${CMAKE_CURRENT_LIST_DIR}/KF5AkonadiCalendarTargets.cmake")
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment