Commit 0fbe4700 authored by Christophe Giboudeaux's avatar Christophe Giboudeaux
Browse files

Fix the akonadi-mime dependencies

Summary: Add the missing linked targets and remove the unneeded dependencies.

Reviewers: mlaurent

Reviewed By: mlaurent

Subscribers: kde-pim

Tags: #kde_pim

Differential Revision: https://phabricator.kde.org/D21210
parent 4454510d
......@@ -20,8 +20,6 @@ include(KDECMakeSettings)
include(KDEFrameworkCompilerSettings NO_POLICY_SCOPE)
include(ECMQtDeclareLoggingCategory)
set(AKONADI_MIME_VERSION ${PIM_VERSION})
set(AKONADI_VERSION "5.11.1")
set(KF5_MIME_VERSION "5.11.1")
......@@ -33,9 +31,10 @@ ecm_setup_version(PROJECT VARIABLE_PREFIX AKONADIMIME
)
########### Find packages ###########
find_package(KF5Codecs ${KF5_MIN_VERSION} CONFIG REQUIRED)
find_package(KF5ConfigWidgets ${KF5_MIN_VERSION} CONFIG REQUIRED)
find_package(KF5DBusAddons ${KF5_MIN_VERSION} CONFIG REQUIRED)
find_package(KF5KIO ${KF5_MIN_VERSION} CONFIG REQUIRED)
find_package(KF5Config ${KF5_MIN_VERSION} CONFIG REQUIRED)
find_package(KF5I18n ${KF5_MIN_VERSION} CONFIG REQUIRED)
find_package(KF5XmlGui ${KF5_MIN_VERSION} CONFIG REQUIRED)
find_package(KF5Mime ${KF5_MIME_VERSION} CONFIG REQUIRED)
......
......@@ -20,7 +20,6 @@ macro(add_akonadi_isolated_test _source)
add_executable(${_targetName} ${_srcList})
target_link_libraries(${_targetName}
Qt5::Test
KF5::MailTransport
KF5::Mime
KF5::AkonadiMime
Qt5::Widgets
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment