Commit a655c95a authored by Laurent Montel's avatar Laurent Montel 😁
Browse files

GIT_SILENT: Time to increase version

parent e51f7536
Pipeline #69882 skipped
......@@ -4,7 +4,7 @@ set(PIM_VERSION "5.18.40")
project(Akonadi-Mime VERSION ${PIM_VERSION})
# ECM setup
set(KF5_MIN_VERSION "5.83.0")
set(KF5_MIN_VERSION "5.84.0")
find_package(ECM ${KF5_MIN_VERSION} CONFIG REQUIRED)
set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH})
......@@ -24,8 +24,8 @@ include(KDEGitCommitHooks)
include(ECMQtDeclareLoggingCategory)
set(AKONADI_MIME_VERSION ${PIM_VERSION})
set(AKONADI_VERSION "5.17.80")
set(KF5_MIME_VERSION "5.17.80")
set(AKONADI_VERSION "5.18.40")
set(KF5_MIME_VERSION "5.18.40")
ecm_setup_version(PROJECT VARIABLE_PREFIX AKONADIMIME
VERSION_HEADER "${CMAKE_CURRENT_BINARY_DIR}/akonadi-mime_version.h"
......@@ -56,7 +56,7 @@ set_package_properties(LibXslt PROPERTIES
########### Targets ###########
add_definitions(-DQT_DISABLE_DEPRECATED_BEFORE=0x050f00)
add_definitions(-DKF_DISABLE_DEPRECATED_BEFORE_AND_AT=0x055400)
add_definitions(-DKF_DISABLE_DEPRECATED_BEFORE_AND_AT=0x055500)
set(CMAKE_CXX_STANDARD 17)
set(CMAKE_CXX_STANDARD_REQUIRED ON)
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment