Commit 7cc80667 authored by Christophe Giboudeaux's avatar Christophe Giboudeaux
Browse files

Add some missing dependencies in KF5AkonadiConfig.cmake

Summary: These libraries are public link targets and must be searched before using the Akonadi libraries.

Reviewers: dvratil, mlaurent

Reviewed By: mlaurent

Subscribers: kde-pim

Tags: #kde_pim

Differential Revision: https://phabricator.kde.org/D21206
parent f99dfabb
......@@ -6,12 +6,25 @@ if(NOT AKONADI_INSTALL_DIR)
endif(NOT AKONADI_INSTALL_DIR)
include(CMakeFindDependencyMacro)
find_dependency(KF5Completion "@KF5_MIN_VERSION@")
find_dependency(KF5XmlGui "@KF5_MIN_VERSION@")
find_dependency(KF5ItemModels "@KF5_MIN_VERSION@")
find_dependency(KF5Config "@KF5_MIN_VERSION@")
find_dependency(KF5ConfigWidgets "@KF5_MIN_VERSION@")
find_dependency(KF5CoreAddons "@KF5_MIN_VERSION@")
find_dependency(KF5ItemModels "@KF5_MIN_VERSION@")
find_dependency(KF5XmlGui "@KF5_MIN_VERSION@")
find_dependency(Qt5Core "@QT_REQUIRED_VERSION@")
find_dependency(Qt5DBus "@QT_REQUIRED_VERSION@")
find_dependency(Qt5Gui "@QT_REQUIRED_VERSION@")
find_dependency(Qt5Network "@QT_REQUIRED_VERSION@")
find_dependency(Qt5Widgets "@QT_REQUIRED_VERSION@")
find_dependency(Qt5Xml "@QT_REQUIRED_VERSION@")
if(BUILD_TESTING)
# Link targets required by KF5AkonadiMacros.cmake
find_dependency(KF5DBusAddons "@KF5_MIN_VERSION@")
find_dependency(KF5KIO "@KF5_MIN_VERSION@")
find_dependency(Qt5Test "@QT_REQUIRED_VERSION@")
endif()
set_and_check(AKONADI_DBUS_INTERFACES_DIR "@PACKAGE_AKONADI_DBUS_INTERFACES_INSTALL_DIR@")
set_and_check(AKONADI_INCLUDE_DIR "@PACKAGE_AKONADI_INCLUDE_DIR@")
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment