Commit 5826c2be authored by Laurent Montel's avatar Laurent Montel 😁
Browse files

Adapt to new plugin api

parent 54243077
Pipeline #188059 passed with stage
in 1 minute and 25 seconds
......@@ -47,7 +47,7 @@ set(KDEPIM_LIB_SOVERSION "5")
set(QT_REQUIRED_VERSION "5.15.2")
set(GPGME_LIB_VERSION "1.16.0")
set(KONTACTINTERFACE_LIB_VERSION "5.20.40")
set(KONTACTINTERFACE_LIB_VERSION "5.20.41")
set(KPIMTEXTEDIT_LIB_VERSION "5.20.40")
set(LIBGRANTLEETHEME_LIB_VERSION "5.20.40")
set(LIBKDEPIM_LIB_VERSION "5.20.40")
......@@ -98,9 +98,9 @@ include_directories(${akregator_SOURCE_DIR} ${akregator_BINARY_DIR})
add_definitions(-DTRANSLATION_DOMAIN=\"akregator\")
ecm_set_disabled_deprecation_versions(QT 5.15.2
KF 5.95.0
KCOREADDONS 5.88.0 #KPluginFactory::registerPlugin
KSERVICE 5.89.0 #KServiceTypeTrader::self
KPARTS 5.89.0 #setPluginLoadingMode
KCOREADDONS 5.88.0 #KPluginFactory::registerPlugin (remove it when we depend against kf5.95)
)
if (TARGET KUserFeedbackWidgets)
add_definitions(-DWITH_KUSERFEEDBACK)
......
......@@ -21,8 +21,8 @@
EXPORT_KONTACT_PLUGIN_WITH_JSON(AkregatorPlugin, "akregatorplugin.json")
AkregatorPlugin::AkregatorPlugin(KontactInterface::Core *core, const QVariantList &)
: KontactInterface::Plugin(core, core, "akregator")
AkregatorPlugin::AkregatorPlugin(KontactInterface::Core *core, const KPluginMetaData &data, const QVariantList &)
: KontactInterface::Plugin(core, core, data, "akregator")
{
setComponentName(QStringLiteral("akregator"), i18n("Akregator"));
......
......@@ -48,7 +48,7 @@ class AkregatorPlugin : public KontactInterface::Plugin
Q_OBJECT
public:
AkregatorPlugin(KontactInterface::Core *core, const QVariantList &);
AkregatorPlugin(KontactInterface::Core *core, const KPluginMetaData &, const QVariantList &);
~AkregatorPlugin() override;
int weight() const override
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment