Commit af370d14 authored by Laurent Montel's avatar Laurent Montel 😁
Browse files

We depend against 5.84

parent 6185751f
Pipeline #73777 failed with stage
in 2 minutes and 48 seconds
......@@ -612,11 +612,7 @@ void Part::showOptions()
const QVector<KPluginMetaData> availablePlugins = KPluginLoader::findPlugins(QStringLiteral("pim/kcms/akregator"));
for (const KPluginMetaData &metaData : availablePlugins) {
#if KCMUTILS_VERSION >= QT_VERSION_CHECK(5, 84, 0)
m_dialog->addModule(metaData);
#else
m_dialog->addModule(metaData.pluginId());
#endif
}
}
......
......@@ -156,7 +156,7 @@ void MainWindow::readProperties(const KConfigGroup &config)
// TODO: move to part?
void MainWindow::optionsConfigureKeys()
{
#if KXMLGUI_VERSION <= QT_VERSION_CHECK(5, 84, 0)
#if KXMLGUI_VERSION < QT_VERSION_CHECK(5, 85, 0)
KShortcutsDialog dlg(KShortcutsEditor::AllActions, KShortcutsEditor::LetterShortcutsAllowed, this);
#else
KShortcutsDialog dlg(this);
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment