Commit 9db2b08e authored by Laurent Montel's avatar Laurent Montel 😁

GIT_SILENT: increase cmake version

parent 4c5473a3
cmake_minimum_required(VERSION 2.8.12)
cmake_minimum_required(VERSION 3.0)
set(PIM_VERSION "5.4.40")
project(calendarsupport)
project(calendarsupport VERSION ${PIM_VERSION})
set(KF5_VERSION "5.28.0")
find_package(ECM ${KF5_VERSION} CONFIG REQUIRED)
......@@ -21,7 +22,6 @@ include(ECMAddTests)
include(ECMCoverageOption)
set(PIM_VERSION "5.4.40")
set(CALENDARSUPPORT_LIB_VERSION ${PIM_VERSION})
set(AKONADI_MIMELIB_VERSION "5.4.40")
......@@ -50,7 +50,7 @@ find_package(KF5AkonadiCalendar ${AKONADICALENDAR_LIB_VERSION} CONFIG REQUIRED)
find_package(KF5PimCommon ${PIMCOMMON_LIB_VERSION} CONFIG REQUIRED)
find_package(KF5KdepimDBusInterfaces ${KDEPIM_LIB_VERSION} CONFIG REQUIRED)
ecm_setup_version(${CALENDARSUPPORT_LIB_VERSION} VARIABLE_PREFIX CALENDARSUPPORT
ecm_setup_version(PROJECT VARIABLE_PREFIX CALENDARSUPPORT
VERSION_HEADER "${CMAKE_CURRENT_BINARY_DIR}/calendarsupport_version.h"
PACKAGE_VERSION_FILE "${CMAKE_CURRENT_BINARY_DIR}/KF5CalendarSupportConfigVersion.cmake"
SOVERSION 5
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment