Commit 7b5623c7 authored by Laurent Montel's avatar Laurent Montel 😁

Search Qt5::Test when it's necessary

parent 699e17f6
...@@ -36,7 +36,7 @@ set(LIBKDEPIM_LIB_VERSION "5.6.40") ...@@ -36,7 +36,7 @@ set(LIBKDEPIM_LIB_VERSION "5.6.40")
set(CALENDARSUPPORT_LIB_VERSION "5.6.40") set(CALENDARSUPPORT_LIB_VERSION "5.6.40")
find_package(KF5Akonadi ${AKONADI_LIB_VERSION} CONFIG REQUIRED) find_package(KF5Akonadi ${AKONADI_LIB_VERSION} CONFIG REQUIRED)
find_package(Qt5 ${QT_REQUIRED_VERSION} CONFIG REQUIRED Widgets Test UiTools) find_package(Qt5 ${QT_REQUIRED_VERSION} CONFIG REQUIRED Widgets UiTools)
find_package(KF5I18n ${KF5_VERSION} CONFIG REQUIRED) find_package(KF5I18n ${KF5_VERSION} CONFIG REQUIRED)
find_package(KF5Codecs ${KF5_VERSION} CONFIG REQUIRED) find_package(KF5Codecs ${KF5_VERSION} CONFIG REQUIRED)
find_package(KF5LibkdepimAkonadi ${LIBKDEPIM_LIB_VERSION} CONFIG REQUIRED) find_package(KF5LibkdepimAkonadi ${LIBKDEPIM_LIB_VERSION} CONFIG REQUIRED)
...@@ -89,6 +89,7 @@ install(FILES ...@@ -89,6 +89,7 @@ install(FILES
add_subdirectory(src) add_subdirectory(src)
if (BUILD_TESTING) if (BUILD_TESTING)
find_package(Qt5 ${QT_REQUIRED_VERSION} CONFIG REQUIRED Test)
add_subdirectory(tests) add_subdirectory(tests)
endif() endif()
install( FILES eventviews.renamecategories eventviews.categories DESTINATION ${KDE_INSTALL_CONFDIR} ) install( FILES eventviews.renamecategories eventviews.categories DESTINATION ${KDE_INSTALL_CONFDIR} )
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment