Commit 879e5fb9 authored by Laurent Montel's avatar Laurent Montel 😁
Browse files

Adapt build system for building against qt6

parent 676b8f98
Pipeline #169631 passed with stage
in 2 minutes and 3 seconds
......@@ -10,7 +10,7 @@ set (RELEASE_SERVICE_VERSION_MICRO "70")
set (RELEASE_SERVICE_VERSION "${RELEASE_SERVICE_VERSION_MAJOR}.${RELEASE_SERVICE_VERSION_MINOR}.${RELEASE_SERVICE_VERSION_MICRO}")
project(itinerary VERSION ${RELEASE_SERVICE_VERSION})
set(KF5_MIN_VERSION 5.88)
set(KF5_MIN_VERSION 5.90)
find_package(ECM ${KF5_MIN_VERSION} REQUIRED NO_MODULE)
set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR} ${CMAKE_SOURCE_DIR}/cmake)
......@@ -44,8 +44,8 @@ endif()
set(QT_MIN_VERSION 5.15.2)
# build-time dependencies
find_package(Qt5 ${QT_MIN_VERSION} REQUIRED COMPONENTS Test Quick Positioning Location QuickControls2)
find_package(Qt5 CONFIG QUIET OPTIONAL_COMPONENTS QuickCompiler)
find_package(Qt${QT_MAJOR_VERSION} ${QT_MIN_VERSION} REQUIRED COMPONENTS Test Quick Positioning Location QuickControls2)
find_package(Qt${QT_MAJOR_VERSION} CONFIG QUIET OPTIONAL_COMPONENTS QuickCompiler)
find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS I18n CoreAddons Contacts Notifications)
find_package(KF5 ${KF5_MIN_VERSION} OPTIONAL_COMPONENTS Holidays UnitConversion NetworkManagerQt)
find_package(KPimPkPass CONFIG REQUIRED)
......@@ -72,7 +72,7 @@ endif()
# runtime dependencies are build-time dependencies on Android
if (ANDROID)
find_package(Qt5 REQUIRED COMPONENTS AndroidExtras Svg)
find_package(Qt${QT_MAJOR_VERSION} REQUIRED COMPONENTS AndroidExtras Svg)
find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS Archive Kirigami2 Prison)
if (NOT DEFINED BREEZEICONS_DIR AND EXISTS ${CMAKE_SOURCE_DIR}/../breeze-icons)
set(BREEZEICONS_DIR ${CMAKE_SOURCE_DIR}/../breeze-icons)
......@@ -80,7 +80,7 @@ if (ANDROID)
find_package(OpenSSL REQUIRED)
find_package(Gradle REQUIRED)
else()
find_package(Qt5 REQUIRED COMPONENTS Widgets DBus)
find_package(Qt${QT_MAJOR_VERSION} REQUIRED COMPONENTS Widgets DBus)
find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS DBusAddons QQC2DesktopStyle)
find_package(KF5 ${KF5_MIN_VERSION} OPTIONAL_COMPONENTS Solid Crash FileMetaData KIO)
endif()
......
......@@ -5,7 +5,7 @@ set(itinerarythumbnail_SRCS itinerarycreator.cpp)
add_library(itinerarythumbnail MODULE ${itinerarythumbnail_SRCS})
target_link_libraries(itinerarythumbnail
KF5::KIOWidgets
Qt5::Gui
Qt::Gui
KPim::PkPass
)
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment