Commit 7a667261 authored by Laurent Montel's avatar Laurent Montel 😁
Browse files

Fix some compile error against qt6

parent 62d5c624
Pipeline #140974 passed with stage
in 2 minutes and 56 seconds
......@@ -111,7 +111,11 @@ if (NOT APPLE)
find_package(X11)
endif()
if (X11_FOUND)
find_package(Qt${QT_MAJOR_VERSION}X11Extras ${QT_REQUIRED_VERSION} REQUIRED NO_MODULE)
if (QT_MAJOR_VERSION STREQUAL "5")
find_package(Qt5X11Extras ${QT_REQUIRED_VERSION} REQUIRED NO_MODULE)
else()
#TODO
endif()
endif()
set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH})
......
......@@ -315,7 +315,7 @@ install(FILES data/org.kde.kalarm.appdata.xml DESTINATION ${KDE_INSTALL_METAINFO
install(FILES data/kalarmconfig.kcfg DESTINATION ${KDE_INSTALL_KCFGDIR})
install(FILES data/kalarmui.rc DESTINATION ${KDE_INSTALL_KXMLGUIDIR}/kalarm)
install(FILES data/org.kde.kalarm.kalarm.xml DESTINATION ${KDE_INSTALL_DBUSINTERFACEDIR})
install(FILES data/kalarm.notifyrc DESTINATION ${KDE_INSTALL_KNOTIFY5RCDIR})
install(FILES data/kalarm.notifyrc DESTINATION ${KDE_INSTALL_KNOTIFYRCDIR})
########### KAuth helper ###############
......
......@@ -5,10 +5,13 @@
*
* SPDX-License-Identifier: GPL-2.0-or-later
*/
#include <QObject>
#pragma once
#if QT_VERSION < QT_VERSION_CHECK(6, 0, 0)
#include <KAuth>
#else
#include <KAuth/KAuth>
#endif
using namespace KAuth;
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment