Commit b9b7bf17 authored by Volker Krause's avatar Volker Krause
Browse files

Fix build with Qt 5.15

There's a number of deprecated API uses in here still that will need to
be adjusted before disabling deprecated API in 5.15 can be done.
parent 417e07d1
Pipeline #24489 passed with stage
in 10 minutes and 47 seconds
......@@ -120,7 +120,7 @@ add_definitions(-DQT_NO_FOREACH)
add_definitions(-DQT_NO_KEYWORDS)
set(CMAKE_CXX_STANDARD 14)
set(CMAKE_CXX_STANDARD_REQUIRED ON)
add_definitions(-DQT_DISABLE_DEPRECATED_BEFORE=0x050f00)
add_definitions(-DQT_DISABLE_DEPRECATED_BEFORE=0x050e00)
add_definitions(-DKF_DISABLE_DEPRECATED_BEFORE_AND_AT=0x054700)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment