Commit 1f9cc88e authored by Laurent Montel's avatar Laurent Montel 😁
Browse files

Adapt to new api

parent c5b0a824
Pipeline #68839 passed with stage
in 62 minutes and 45 seconds
......@@ -73,7 +73,7 @@ set(LIBKLEO_LIB_VERSION "5.17.40")
set(AKONADI_LIB_VERSION "5.17.40")
set(INCIDENCEEDITOR_LIB_VERSION "5.17.40")
set(KTNEF_LIB_VERSION "5.17.40")
set(MESSAGELIB_LIB_VERSION "5.17.55")
set(MESSAGELIB_LIB_VERSION "5.17.56")
set(AKONADICALENDAR_LIB_VERSION "5.17.40")
set(CALENDAR_UTILS_VERSION "5.17.40")
set(KPIMTEXTEDIT_LIB_VERSION "5.17.40")
......
......@@ -6,6 +6,7 @@
#include "confirmbeforedeletingplugin.h"
#include "confirmbeforedeletingdialog.h"
#include "confirmbeforedeletinginterface.h"
#include <KPluginFactory>
K_PLUGIN_CLASS_WITH_JSON(ConfirmBeforeDeletingPlugin, "kmail_confirmbeforedeletingplugin.json")
......@@ -25,4 +26,9 @@ void ConfirmBeforeDeletingPlugin::showConfigureDialog(QWidget *parent)
dlg.exec();
}
MessageViewer::MessageViewerCheckBeforeDeletingInterface *ConfirmBeforeDeletingPlugin::createInterface(QObject *parent)
{
return new ConfirmBeforeDeletingInterface(parent);
}
#include "confirmbeforedeletingplugin.moc"
......@@ -15,4 +15,5 @@ public:
~ConfirmBeforeDeletingPlugin() override;
void showConfigureDialog(QWidget *parent) override;
Q_REQUIRED_RESULT MessageViewer::MessageViewerCheckBeforeDeletingInterface *createInterface(QObject *parent) override;
};
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment