Commit 2a798d19 authored by Laurent Montel's avatar Laurent Montel 😁
Browse files

GIT_SILENT: master is open. + increase depend

parent 1de021fd
Pipeline #54191 skipped
cmake_minimum_required(VERSION 3.5 FATAL_ERROR)
set(PIM_VERSION "5.16.80")
set(PIM_VERSION "5.17.40")
project(kdepim-addons VERSION ${PIM_VERSION})
if(POLICY CMP0063)
cmake_policy(SET CMP0063 NEW)
endif()
set(KF5_MIN_VERSION "5.79.0")
set(KF5_MIN_VERSION "5.80.0")
find_package(ECM ${KF5_MIN_VERSION} CONFIG REQUIRED)
set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules/ ${ECM_MODULE_PATH})
# Do NOT add quote
set(KDEPIM_DEV_VERSION beta)
set(KDEPIM_DEV_VERSION alpha)
# add an extra space
if(DEFINED KDEPIM_DEV_VERSION)
......@@ -146,7 +146,7 @@ endif()
find_package(Gpgmepp 1.13.1 CONFIG)
set_package_properties(Gpgmepp PROPERTIES DESCRIPTION "GpgME library" URL "https://www.gnupg.org" TYPE REQUIRED)
add_definitions(-DQT_DISABLE_DEPRECATED_BEFORE=0x050e00)
add_definitions(-DKF_DISABLE_DEPRECATED_BEFORE_AND_AT=0x055000)
add_definitions(-DKF_DISABLE_DEPRECATED_BEFORE_AND_AT=0x055100)
option(KDEPIM_RUN_AKONADI_TEST "Enable autotest based on Akonadi." TRUE)
include_directories(${CMAKE_CURRENT_SOURCE_DIR})
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment