Commit 5479c732 authored by Laurent Montel's avatar Laurent Montel 😁
Browse files

Fix build import/export plugins.

Need to use kaddressbook dependancy as this lib is from long time in
kaddressbook

BUG: 432228
parent b9b4b389
Pipeline #110953 failed with stage
in 42 seconds
......@@ -99,7 +99,7 @@ find_package(KF5WebEngineViewer ${MESSAGELIB_LIB_VERSION} CONFIG REQUIRED)
find_package(KF5TemplateParser ${MESSAGELIB_LIB_VERSION} CONFIG REQUIRED)
find_package(KF5MailCommon ${MAILCOMMON_LIB_VERSION} CONFIG REQUIRED)
find_package(KF5MessageViewer ${MESSAGELIB_LIB_VERSION} CONFIG REQUIRED)
find_package(KPimAddressbookImportExport ${KADDRESSBOOK_IMPORTEXPORT_LIB_VERSION} CONFIG)
find_package(KPimAddressbookImportExport ${KADDRESSBOOK_IMPORTEXPORT_LIB_VERSION} CONFIG REQUIRED)
find_package(KF5Libkleo ${LIBKLEO_LIB_VERSION} CONFIG REQUIRED)
find_package(KF5GrantleeTheme ${GRANTLEETHEME_LIB_VERSION} CONFIG REQUIRED)
find_package(KF5PimCommonAkonadi ${PIMCOMMON_LIB_VERSION} CONFIG REQUIRED)
......
......@@ -3,8 +3,4 @@
add_subdirectory( editorpages )
add_subdirectory( plugins )
if (KPimAddressbookImportExport_FOUND)
add_subdirectory( importexportplugins )
else()
MESSAGE(STATUS "You need to build kaddressbook first and add install it on distro before building kdepim-addons. Otherwise import/export will be missing in kaddressbook")
endif()
add_subdirectory( importexportplugins )
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment