Commit 825fed25 authored by Laurent Montel's avatar Laurent Montel 😁

Use new api

parent 2e8293ae
......@@ -69,7 +69,7 @@ set(KDEPIMLIBS_LIB_VERSION "5.2.40")
set(GRAVATAR_LIB_VERSION "5.2.40")
set(INCIDENCEEDITOR_LIB_VERSION "5.2.40")
set(KTNEF_LIB_VERSION "5.2.40")
set(MESSAGELIB_LIB_VERSION "5.2.74")
set(MESSAGELIB_LIB_VERSION "5.2.76")
set(AKONADICALENDAR_LIB_VERSION "5.2.40")
find_package(KF5WebEngineViewer ${MESSAGELIB_LIB_VERSION} CONFIG REQUIRED)
......
......@@ -32,8 +32,9 @@ ConfirmAddressInterface::~ConfirmAddressInterface()
}
bool ConfirmAddressInterface::exec()
bool ConfirmAddressInterface::exec(const MessageComposer::PluginEditorCheckBeforeSendParams &params)
{
//TODO use params
if (mEnabled) {
//TODO
return true;
......
......@@ -28,7 +28,7 @@ class ConfirmAddressInterface : public MessageComposer::PluginEditorCheckBeforeS
public:
explicit ConfirmAddressInterface(QObject *parent = Q_NULLPTR);
~ConfirmAddressInterface();
bool exec() Q_DECL_OVERRIDE;
bool exec(const MessageComposer::PluginEditorCheckBeforeSendParams &params) Q_DECL_OVERRIDE;
public Q_SLOTS:
void reloadConfig() Q_DECL_OVERRIDE;
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment