Commit 8343e0d7 authored by Laurent Montel's avatar Laurent Montel 😁

GIT_SILENT: use KF5_MIN_VERSION

parent ff0782d8
......@@ -2,10 +2,10 @@ cmake_minimum_required(VERSION 3.5)
project(%{ProjectName})
set(KF5_VERSION "5.50.0")
set(KF5_MIN_VERSION "5.50.0")
set(QT_REQUIRED_VERSION "5.9.0")
find_package(ECM ${KF5_VERSION} CONFIG REQUIRED)
find_package(ECM ${KF5_MIN_VERSION} CONFIG REQUIRED)
set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH})
include(ECMInstallIcons)
......@@ -27,10 +27,10 @@ include(ECMQtDeclareLoggingCategory)
find_package(Qt5 ${QT_REQUIRED_VERSION} CONFIG REQUIRED Widgets Test)
find_package(KF5I18n ${KF5_VERSION} CONFIG REQUIRED)
find_package(KF5XmlGui ${KF5_VERSION} CONFIG REQUIRED)
find_package(KF5IconThemes ${KF5_VERSION} CONFIG REQUIRED)
find_package(KF5KIO ${KF5_VERSION} CONFIG REQUIRED)
find_package(KF5I18n ${KF5_MIN_VERSION} CONFIG REQUIRED)
find_package(KF5XmlGui ${KF5_MIN_VERSION} CONFIG REQUIRED)
find_package(KF5IconThemes ${KF5_MIN_VERSION} CONFIG REQUIRED)
find_package(KF5KIO ${KF5_MIN_VERSION} CONFIG REQUIRED)
set(MESSAGELIB_LIB_VERSION "5.9.0")
......
......@@ -2,10 +2,10 @@ cmake_minimum_required(VERSION 3.5)
project(%{ProjectName})
set(KF5_VERSION "5.50.0")
set(KF5_MIN_VERSION "5.50.0")
set(QT_REQUIRED_VERSION "5.9.0")
find_package(ECM ${KF5_VERSION} CONFIG REQUIRED)
find_package(ECM ${KF5_MIN_VERSION} CONFIG REQUIRED)
set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH})
include(ECMInstallIcons)
......@@ -27,10 +27,10 @@ include(ECMQtDeclareLoggingCategory)
find_package(Qt5 ${QT_REQUIRED_VERSION} CONFIG REQUIRED Widgets Test)
find_package(KF5I18n ${KF5_VERSION} CONFIG REQUIRED)
find_package(KF5XmlGui ${KF5_VERSION} CONFIG REQUIRED)
find_package(KF5IconThemes ${KF5_VERSION} CONFIG REQUIRED)
find_package(KF5KIO ${KF5_VERSION} CONFIG REQUIRED)
find_package(KF5I18n ${KF5_MIN_VERSION} CONFIG REQUIRED)
find_package(KF5XmlGui ${KF5_MIN_VERSION} CONFIG REQUIRED)
find_package(KF5IconThemes ${KF5_MIN_VERSION} CONFIG REQUIRED)
find_package(KF5KIO ${KF5_MIN_VERSION} CONFIG REQUIRED)
set(MESSAGELIB_LIB_VERSION "5.9.0")
......
########### next target ###############
find_package(KF5KDELibs4Support ${KF5_VERSION} CONFIG REQUIRED) #for the korganizer hebrew plugin
find_package(KF5KDELibs4Support ${KF5_MIN_VERSION} CONFIG REQUIRED) #for the korganizer hebrew plugin
set(korg_hebrew_PART_SRCS
qcalendarsystem.cpp
configdialog.cpp
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment