Commit a93da174 authored by Laurent Montel's avatar Laurent Montel 😁
Browse files

We need Qt6Core5Compat

parent d54d5510
Pipeline #177485 passed with stage
in 10 minutes and 53 seconds
......@@ -54,6 +54,10 @@ option(KDEPIM_ENTERPRISE_BUILD "Enable features specific to the enterprise branc
find_package(Qt${QT_MAJOR_VERSION} ${QT_REQUIRED_VERSION} CONFIG REQUIRED WebEngineWidgets Widgets Test)
if (QT_MAJOR_VERSION STREQUAL "6")
find_package(Qt6Core5Compat)
endif()
find_package(KF5I18n ${KF5_MIN_VERSION} CONFIG REQUIRED)
find_package(KF5Config ${KF5_MIN_VERSION} CONFIG REQUIRED)
find_package(KF5DBusAddons ${KF5_MIN_VERSION} CONFIG REQUIRED)
......
......@@ -16,6 +16,9 @@ macro(add_kdepimaddons_crypto_unittest _source)
Qt${QT_MAJOR_VERSION}::Test
)
if (TARGET Qt6::Core5Compat)
target_link_libraries(${_name} Qt6::Core5Compat)
endif()
add_gpg_crypto_test(${_name} messageviewerplugins-${_name})
ecm_mark_as_test(messageviewerplugins-${_name})
endmacro ()
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment