Commit c9b2c73f authored by Laurent Montel's avatar Laurent Montel 😁
Browse files

GIT_SILENT: Prepare 5.14.0 beta1.

parent 1fb34f48
......@@ -25,7 +25,7 @@ set(KDEPIMADDONS_VERSION "${KDEPIMADDONS_VERSION_NUMBER}${KDEPIM_DEV_VERSION}")
set(KDEPIMADDONS_LIB_VERSION "${KDEPIMADDONS_VERSION_NUMBER}")
set(KDEPIMADDONS_LIB_SOVERSION "5")
set(AKONADINOTES_LIB_VERSION "5.13.40")
set(AKONADINOTES_LIB_VERSION "5.13.80")
set(QT_REQUIRED_VERSION "5.12.0")
......@@ -64,32 +64,32 @@ find_package(KF5Parts ${KF5_MIN_VERSION} CONFIG REQUIRED)
find_package(KF5Prison ${KF5_MIN_VERSION} CONFIG REQUIRED)
find_package(KF5Holidays ${KF5_MIN_VERSION} CONFIG REQUIRED)
set(MAILCOMMON_LIB_VERSION "5.13.40")
set(GRAVATAR_LIB_VERSION "5.13.40")
set(PIMCOMMON_LIB_VERSION "5.13.40")
set(GRANTLEETHEME_LIB_VERSION "5.13.40")
set(CALENDARSUPPORT_LIB_VERSION "5.13.40")
set(EVENTVIEW_LIB_VERSION "5.13.40")
set(LIBKDEPIM_LIB_VERSION "5.13.40")
set(KDEPIM_APPS_LIB_VERSION "5.13.40")
set(LIBKLEO_LIB_VERSION "5.13.40")
set(AKONADI_LIB_VERSION "5.13.40")
set(INCIDENCEEDITOR_LIB_VERSION "5.13.40")
set(KTNEF_LIB_VERSION "5.13.40")
set(MESSAGELIB_LIB_VERSION "5.13.56")
set(AKONADICALENDAR_LIB_VERSION "5.13.40")
set(CALENDAR_UTILS_VERSION "5.13.40")
set(KPIMTEXTEDIT_LIB_VERSION "5.13.40")
set(KIMAP_LIB_VERSION "5.13.40")
set(LIBKSIEVE_LIB_VERSION "5.13.40")
set(KMAILTRANSPORT_LIB_VERSION "5.13.40")
set(AKONADICONTACT_LIB_VERSION "5.13.40")
set(IMPORTWIZARD_LIB_VERSION "5.13.40")
set(MAILIMPORTER_LIB_VERSION "5.13.40")
set(KPIMPKPASS_LIB_VERSION "5.13.40")
set(KPIMITINERARY_LIB_VERSION "5.13.40")
set(KONTACTINTERFACE_LIB_VERSION "5.13.40")
set(CALENDARSUPPORT_LIB_VERSION_LIB "5.13.40")
set(MAILCOMMON_LIB_VERSION "5.13.80")
set(GRAVATAR_LIB_VERSION "5.13.80")
set(PIMCOMMON_LIB_VERSION "5.13.80")
set(GRANTLEETHEME_LIB_VERSION "5.13.80")
set(CALENDARSUPPORT_LIB_VERSION "5.13.80")
set(EVENTVIEW_LIB_VERSION "5.13.80")
set(LIBKDEPIM_LIB_VERSION "5.13.80")
set(KDEPIM_APPS_LIB_VERSION "5.13.80")
set(LIBKLEO_LIB_VERSION "5.13.80")
set(AKONADI_LIB_VERSION "5.13.80")
set(INCIDENCEEDITOR_LIB_VERSION "5.13.80")
set(KTNEF_LIB_VERSION "5.13.80")
set(MESSAGELIB_LIB_VERSION "5.13.80")
set(AKONADICALENDAR_LIB_VERSION "5.13.80")
set(CALENDAR_UTILS_VERSION "5.13.80")
set(KPIMTEXTEDIT_LIB_VERSION "5.13.80")
set(KIMAP_LIB_VERSION "5.13.80")
set(LIBKSIEVE_LIB_VERSION "5.13.80")
set(KMAILTRANSPORT_LIB_VERSION "5.13.80")
set(AKONADICONTACT_LIB_VERSION "5.13.80")
set(IMPORTWIZARD_LIB_VERSION "5.13.80")
set(MAILIMPORTER_LIB_VERSION "5.13.80")
set(KPIMPKPASS_LIB_VERSION "5.13.80")
set(KPIMITINERARY_LIB_VERSION "5.13.80")
set(KONTACTINTERFACE_LIB_VERSION "5.13.80")
set(CALENDARSUPPORT_LIB_VERSION_LIB "5.13.80")
find_package(KF5CalendarCore ${KF5_MIN_VERSION} CONFIG REQUIRED)
find_package(KF5CalendarUtils ${CALENDAR_UTILS_VERSION} CONFIG REQUIRED)
find_package(KF5WebEngineViewer ${MESSAGELIB_LIB_VERSION} CONFIG REQUIRED)
......@@ -144,7 +144,7 @@ find_package(Gpgmepp 1.11.1 CONFIG)
set_package_properties(Gpgmepp PROPERTIES DESCRIPTION "GpgME library" URL "https://www.gnupg.org" TYPE REQUIRED)
if (EXISTS "${CMAKE_SOURCE_DIR}/.git")
add_definitions(-DQT_DISABLE_DEPRECATED_BEFORE=0x050e00)
add_definitions(-DKF_DISABLE_DEPRECATED_BEFORE_AND_AT=0x058000)
add_definitions(-DKF_DISABLE_DEPRECATED_BEFORE_AND_AT=0x054400)
endif()
add_definitions(-DQT_NO_FOREACH)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment