Commit 396dabe9 authored by Laurent Montel's avatar Laurent Montel 😁

Allow to reload config

parent 56140d07
......@@ -69,7 +69,7 @@ set(KDEPIMLIBS_LIB_VERSION "5.2.40")
set(GRAVATAR_LIB_VERSION "5.2.40")
set(INCIDENCEEDITOR_LIB_VERSION "5.2.40")
set(KTNEF_LIB_VERSION "5.2.40")
set(MESSAGELIB_LIB_VERSION "5.2.72")
set(MESSAGELIB_LIB_VERSION "5.2.73")
set(AKONADICALENDAR_LIB_VERSION "5.2.40")
find_package(KF5WebEngineViewer ${MESSAGELIB_LIB_VERSION} CONFIG REQUIRED)
......
......@@ -24,7 +24,7 @@ ConfirmAddressInterface::ConfirmAddressInterface(QObject *parent)
: MessageComposer::PluginEditorCheckBeforeSendInterface(parent),
mEnabled(false)
{
loadConfig();
reloadConfig();
}
ConfirmAddressInterface::~ConfirmAddressInterface()
......@@ -42,7 +42,7 @@ bool ConfirmAddressInterface::exec()
}
}
void ConfirmAddressInterface::loadConfig()
void ConfirmAddressInterface::reloadConfig()
{
//TODO
}
......@@ -30,8 +30,10 @@ public:
~ConfirmAddressInterface();
bool exec() Q_DECL_OVERRIDE;
public Q_SLOTS:
void reloadConfig() Q_DECL_OVERRIDE;
private:
void loadConfig();
bool mEnabled;
};
......
......@@ -40,6 +40,7 @@ ConfirmAddressPlugin::~ConfirmAddressPlugin()
MessageComposer::PluginEditorCheckBeforeSendInterface *ConfirmAddressPlugin::createInterface(QObject *parent)
{
ConfirmAddressInterface *interface = new ConfirmAddressInterface(parent);
connect(this, &ConfirmAddressPlugin::configChanged, interface, &ConfirmAddressInterface::reloadConfig);
return interface;
}
......
......@@ -34,7 +34,6 @@ public:
bool hasConfigureSupport() const Q_DECL_OVERRIDE;
MessageComposer::PluginEditorCheckBeforeSendConfigureWidgetSetting createConfigureWidget(QWidget *parent) const Q_DECL_OVERRIDE;
};
#endif // CONFIRMADDRESSPLUGIN_H
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment