Commit 8a373cf9 authored by Laurent Montel's avatar Laurent Montel 😁

Use correct variable

parent 0a848644
......@@ -20,11 +20,14 @@ include(ECMAddTests)
set(KF5_VERSION "5.16.0")
set(KDEPIMLIBS_LIB_VERSION "5.1.42")
set(KDEPIM_LIB_VERSION "5.1.42")
set(KDEPIM_APPS_LIB_VERSION "5.1.42")
set(QT_REQUIRED_VERSION "5.4.0")
set(KMIME_LIB_VERSION "4.87.0")
set(KPIMTEXTEDIT_LIB_VERSION "5.1.42")
set(KCONTACTS_LIB_VERSION "4.92.0")
set(PIMCOMMON_LIB_VERSION "5.1.42")
set(LIBKLEO_LIB_VERSION "5.1.42")
set(GRANTLEETHEME_LIB_VERSION "5.1.42")
find_package(KF5Akonadi ${KDEPIMLIBS_LIB_VERSION} CONFIG REQUIRED)
find_package(Qt5 ${QT_REQUIRED_VERSION} CONFIG REQUIRED Widgets Test UiTools WebKitWidgets DBus Gui)
......@@ -33,8 +36,8 @@ find_package(KF5IconThemes ${KF5_VERSION} CONFIG REQUIRED)
find_package(KF5Config ${KF5_VERSION} CONFIG REQUIRED)
find_package(KF5Service ${KF5_VERSION} CONFIG REQUIRED)
find_package(Grantlee5 "5.0" CONFIG REQUIRED)
find_package(KF5Libkleo ${KDEPIM_LIB_VERSION} CONFIG REQUIRED)
find_package(KF5GrantleeTheme ${KDEPIM_LIB_VERSION} CONFIG REQUIRED)
find_package(KF5Libkleo ${LIBKLEO_LIB_VERSION} CONFIG REQUIRED)
find_package(KF5GrantleeTheme ${GRANTLEETHEME_LIB_VERSION} CONFIG REQUIRED)
find_package(KF5AkonadiContact ${KDEPIMLIBS_LIB_VERSION} CONFIG REQUIRED)
find_package(KF5Contacts ${KCONTACTS_LIB_VERSION} CONFIG REQUIRED)
find_package(KF5XmlGui ${KF5_VERSION} CONFIG REQUIRED)
......@@ -44,7 +47,7 @@ find_package(KF5Mime ${KMIME_LIB_VERSION} CONFIG REQUIRED)
find_package(KF5AkonadiMime ${KDEPIMLIBS_LIB_VERSION} CONFIG REQUIRED)
find_package(KF5WebKit ${KF5_VERSION} CONFIG REQUIRED)
find_package(KF5PimTextEdit ${KPIMTEXTEDIT_LIB_VERSION} CONFIG REQUIRED)
find_package(KF5PimCommon ${KDEPIM_LIB_VERSION} CONFIG REQUIRED)
find_package(KF5PimCommon ${PIMCOMMON_LIB_VERSION} CONFIG REQUIRED)
find_package(KF5CoreAddons ${KF5_VERSION} CONFIG REQUIRED)
find_package(KF5DBusAddons ${KF5_VERSION} CONFIG REQUIRED)
find_package(KF5WidgetsAddons ${KF5_VERSION} CONFIG REQUIRED)
......
project(composereditorng)
ecm_setup_version(${KDEPIM_LIB_VERSION} VARIABLE_PREFIX COMPOSEREDITORNG
ecm_setup_version(${KDEPIM_APPS_LIB_VERSION} VARIABLE_PREFIX COMPOSEREDITORNG
VERSION_HEADER "${CMAKE_CURRENT_BINARY_DIR}/composereditorng_version.h"
PACKAGE_VERSION_FILE "${CMAKE_CURRENT_BINARY_DIR}/KF5ComposerEditorNGConfigVersion.cmake"
SOVERSION 5
......
project(kaddressbookgrantlee)
ecm_setup_version(${KDEPIM_LIB_VERSION} VARIABLE_PREFIX KADDRESSBOOKGRANTLEE
ecm_setup_version(${KDEPIM_APPS_LIB_VERSION} VARIABLE_PREFIX KADDRESSBOOKGRANTLEE
VERSION_HEADER "${CMAKE_CURRENT_BINARY_DIR}/kaddressbookgrantlee_version.h"
PACKAGE_VERSION_FILE "${CMAKE_CURRENT_BINARY_DIR}/KF5KaddressbookGrantleeConfigVersion.cmake"
SOVERSION 5
......
project(followupreminder)
ecm_setup_version(${KDEPIM_LIB_VERSION} VARIABLE_PREFIX FOLLOWUPREMINDER
ecm_setup_version(${KDEPIM_APPS_LIB_VERSION} VARIABLE_PREFIX FOLLOWUPREMINDER
VERSION_HEADER "${CMAKE_CURRENT_BINARY_DIR}/followupreminder_version.h"
PACKAGE_VERSION_FILE "${CMAKE_CURRENT_BINARY_DIR}/KF5FollowupReminderConfigVersion.cmake"
SOVERSION 5
......
project(kdepimdbusinterfaces)
ecm_setup_version(${KDEPIM_LIB_VERSION} VARIABLE_PREFIX KDEPIMDBUSINTERFACES
ecm_setup_version(${KDEPIM_APPS_LIB_VERSION} VARIABLE_PREFIX KDEPIMDBUSINTERFACES
VERSION_HEADER "${CMAKE_CURRENT_BINARY_DIR}/kdepimdbusinterfaces_version.h"
PACKAGE_VERSION_FILE "${CMAKE_CURRENT_BINARY_DIR}/KF5KdepimDBusInterfacesConfigVersion.cmake"
SOVERSION 5
......
project(sendlater)
ecm_setup_version(${KDEPIM_LIB_VERSION} VARIABLE_PREFIX SENDLATER
ecm_setup_version(${KDEPIM_APPS_LIB_VERSION} VARIABLE_PREFIX SENDLATER
VERSION_HEADER "${CMAKE_CURRENT_BINARY_DIR}/sendlater_version.h"
PACKAGE_VERSION_FILE "${CMAKE_CURRENT_BINARY_DIR}/KF5SendLaterConfigVersion.cmake"
SOVERSION 5
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment