Commit ea354ea5 authored by Laurent Montel's avatar Laurent Montel 😁
Browse files

Pimcommon is unused

parent d953b40c
Pipeline #84234 failed with stage
in 28 minutes and 14 seconds
......@@ -21,5 +21,4 @@ Dependencies:
'kde/pim/kmbox' : '@same'
'kde/pim/kmime' : '@same'
'kde/pim/libkgapi' : '@same'
'kde/pim/pimcommon' : '@same'
'third-party/libkolabxml' : '@stable'
......@@ -81,7 +81,6 @@ set(KMIME_LIB_VERSION "5.18.40")
set(AKONADIMIME_LIB_VERSION "5.18.41")
set(AKONADICONTACT_LIB_VERSION "5.18.40")
set(AKONADINOTE_LIB_VERSION "5.18.40")
set(PIMCOMMON_LIB_VERSION "5.18.40")
set(KGAPI_LIB_VERSION "5.18.40")
set(LIBKDEPIM_LIB_VERSION "5.18.40")
set(KLDAP_LIB_VERSION "5.18.40")
......@@ -145,7 +144,6 @@ find_package(KF5Mbox ${KMBOX_LIB_VERSION} CONFIG REQUIRED)
find_package(KF5IMAP ${KIMAP_LIB_VERSION} CONFIG REQUIRED)
find_package(KF5AkonadiNotes ${AKONADINOTE_LIB_VERSION} CONFIG REQUIRED)
find_package(KF5AkonadiCalendar ${AKONADICALENDAR_LIB_VERSION} CONFIG REQUIRED)
find_package(KF5PimCommon ${PIMCOMMON_LIB_VERSION} CONFIG REQUIRED)
find_package(KPimGAPI ${KGAPI_LIB_VERSION} CONFIG REQUIRED)
find_package(KF5Libkdepim ${LIBKDEPIM_LIB_VERSION} CONFIG REQUIRED)
find_package(KF5Ldap ${KLDAP_LIB_VERSION} CONFIG REQUIRED)
......
......@@ -86,7 +86,6 @@ target_link_libraries(imapresource
KF5::I18n
KF5::WindowSystem
akonadi-singlefileresource
KF5::PimCommon
KF5::Libkdepim
qt5keychain
)
......
......@@ -69,7 +69,6 @@ target_link_libraries(akonadi_kolab_resource
KF5::Contacts
KF5::CalendarCore
akonadi-singlefileresource
KF5::PimCommon
KF5::TextWidgets
KF5::I18n
)
......
......@@ -48,8 +48,8 @@ target_link_libraries( akonadi_pop3_resource
KF5::I18n
KF5::Notifications
Qt::DBus
KF5::PimCommon
qt5keychain
KF5::WidgetsAddons
)
if (COMPILE_WITH_UNITY_CMAKE_SUPPORT)
set_target_properties(akonadi_pop3_resource PROPERTIES UNITY_BUILD ON)
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment