Commit ca6a0226 authored by Volker Krause's avatar Volker Krause
Browse files

Make missing Poppler internal headers a fatal error

Otherwise making Poppler a required dependency is rather pointless.
parent 23ce1aa6
Pipeline #152811 passed with stages
in 1 minute and 42 seconds
......@@ -71,7 +71,7 @@ if(TARGET Poppler::Core)
# check if we have private Poppler headers
find_file(HAVE_POPPLER_UNSTABLE_HEADERS "OutputDev.h" PATHS ${Poppler_INCLUDE_DIRS} NO_DEFAULT_PATH)
if (NOT HAVE_POPPLER_UNSTABLE_HEADERS)
message(WARNING "Poppler was not build with ENABLE_UNSTABLE_API_ABI_HEADER - building without PDF support!")
message(FATAL_ERROR "Poppler was not build with ENABLE_UNSTABLE_API_ABI_HEADER!")
set(HAVE_POPPLER FALSE)
else()
set(HAVE_POPPLER TRUE)
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment