Commit d6ad8878 authored by Volker Krause's avatar Volker Krause
Browse files

Mark Poppler as required on all platforms, not just on Android

parent 8e85a316
Pipeline #151006 passed with stages
in 3 minutes and 6 seconds
......@@ -49,7 +49,7 @@ find_package(KF5CalendarCore ${KF5_MIN_VERSION} CONFIG)
find_package(KF5Contacts ${KF5_MIN_VERSION} CONFIG REQUIRED)
find_package(KPimPkPass ${PIM_PKPASS} CONFIG REQUIRED)
find_package(Poppler COMPONENTS Core)
set_package_properties("Poppler" PROPERTIES TYPE OPTIONAL PURPOSE "Support for extraction from PDF booking confirmations.")
set_package_properties("Poppler" PROPERTIES TYPE REQUIRED PURPOSE "Support for extraction from PDF booking confirmations.")
find_package(ZXing CONFIG)
set_package_properties("ZXing" PROPERTIES TYPE OPTIONAL PURPOSE "Support for barcode decoding." URL "https://github.com/nu-book/zxing-cpp")
find_package(ZLIB REQUIRED)
......@@ -65,10 +65,6 @@ set_package_properties(OsmTools PROPERTIES TYPE OPTIONAL PURPOSE "Needed only fo
if (NOT ANDROID)
set_package_properties(KF5CalendarCore PROPERTIES TYPE REQUIRED)
set_package_properties(LibXml2 PROPERTIES TYPE REQUIRED)
else()
# force Poppler on Android, to avoid silent failures on binary factory when its
# Poppler build broke, which then results in feature regressions in KDE Itinerary
set_package_properties(Poppler PROPERTIES TYPE REQUIRED)
endif()
if(TARGET Poppler::Core)
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment