Commit 44383870 authored by Volker Krause's avatar Volker Krause
Browse files

Make Poppler a hard requirement on Android

This is to avoid binary factory silently regressing when the Poppler build
failed like it recently happened due to a Freetype repository URL change.
parent 3d99c1f1
Pipeline #37770 passed with stage
in 59 minutes and 8 seconds
......@@ -58,6 +58,10 @@ set_package_properties(OsmTools PROPERTIES TYPE OPTIONAL PURPOSE "Needed only fo
if (NOT ANDROID)
set_package_properties(KF5CalendarCore PROPERTIES TYPE REQUIRED)
set_package_properties(LibXml2 PROPERTIES TYPE REQUIRED)
else()
# force Poppler on Android, to avoid silent failures on binary factory when its
# Poppler build broke, which then results in feature regressions in KDE Itinerary
set_package_properties(Poppler PROPERTIES TYPE REQUIRED)
endif()
if(TARGET Poppler::Core)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment