Commit 8a13ede9 authored by Volker Krause's avatar Volker Krause Committed by David Faure
Browse files

Require C++17

We have things below and above this requiring C++17 already anyway, so this
should not have any practical implications on modules using this. It does
however fix the build with latest ZXing.
parent 769f4a04
Pipeline #38156 passed with stage
in 15 minutes and 49 seconds
......@@ -2,7 +2,7 @@ cmake_minimum_required(VERSION 3.5)
set(PIM_VERSION "5.15.3")
project(KItinerary VERSION ${PIM_VERSION})
set(CMAKE_CXX_STANDARD 14)
set(CMAKE_CXX_STANDARD 17)
set(CMAKE_CXX_STANDARD_REQUIRED ON)
set(KF5_MIN_VERSION "5.71.0")
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment