Verified Commit 37815c17 authored by Andre Heinecke's avatar Andre Heinecke
Browse files

Clarify error message for invalid compliance

It was only visible in the tooltip that signing and encrypting
files was not possible because of compliance settings. This
caused irritation for users.
parent 904a0a28
Pipeline #255824 passed with stage
in 4 minutes and 23 seconds
......@@ -191,7 +191,7 @@ public:
auto messageWidget = new KMessageWidget;
messageWidget->setMessageType(KMessageWidget::Error);
messageWidget->setIcon(style()->standardIcon(QStyle::SP_MessageBoxCritical, nullptr, this));
messageWidget->setText(i18n("Signing and encrypting files is not possible."));
messageWidget->setText(i18n("Invalid compliance settings for signing and encrypting files."));
messageWidget->setToolTip(xi18nc("@info %1 is a placeholder for the name of a compliance mode. E.g. NATO RESTRICTED compliant or VS-NfD compliant",
"<para>You cannot use <application>Kleopatra</application> for signing or encrypting files "
"because the <application>GnuPG</application> system used by <application>Kleopatra</application> is not %1.</para>",
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment