Commit 6c72e583 authored by Laurent Montel's avatar Laurent Montel 😁
Browse files

GIT_SILENT: time to increase qt version as kf5-5.77 will depend against it.

parent 7b3bc559
Pipeline #44616 skipped
......@@ -16,7 +16,7 @@ option(DISABLE_KWATCHGNUPG "Don't build the kwatchgnupg tool [default=OFF]" OFF)
set(KF5_MIN_VERSION "5.77.0")
set(KMIME_VERSION "5.16.40")
set(LIBKLEO_VERSION "5.16.42")
set(QT_REQUIRED_VERSION "5.13.0")
set(QT_REQUIRED_VERSION "5.14.0")
set(GPGME_REQUIRED_VERSION "1.13.1")
if (WIN32)
......
......@@ -118,13 +118,9 @@ void KConfigBasedRecipientPreferences::Private::writePrefs()
if (!m_dirty) {
return;
}
#if QT_VERSION < QT_VERSION_CHECK(5, 14, 0)
const QSet<QByteArray> keys = pgpPrefs.keys().toSet() + cmsPrefs.keys().toSet();
#else
const auto pgpPrefsKeys = pgpPrefs.keys();
const auto cmsPrefsKeys = cmsPrefs.keys();
const QSet<QByteArray> keys = QSet<QByteArray>(pgpPrefsKeys.begin(), pgpPrefsKeys.end()) + QSet<QByteArray>(cmsPrefsKeys.begin(), cmsPrefsKeys.end());
#endif
int n = 0;
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment