Commit d44853ca authored by Laurent Montel's avatar Laurent Montel 😁
Browse files

GIT_SILENT: we still depend against qt5.14 which doesn't have Qt:: support :(

parent ae0d5d19
Pipeline #49324 skipped
......@@ -7,4 +7,4 @@ ecm_qt_declare_logging_category(kuniqueservicetest_src HEADER kleopatra_debug.h
add_executable(kuniqueservicetest ${kuniqueservicetest_src})
add_test(NAME kuniqueservicetest COMMAND kuniqueservicetest)
ecm_mark_as_test(kuniqueservicetest)
target_link_libraries(kuniqueservicetest Qt::Test ${_kleopatra_dbusaddons_libs})
target_link_libraries(kuniqueservicetest Qt5::Test ${_kleopatra_dbusaddons_libs})
......@@ -357,8 +357,8 @@ target_link_libraries(kleopatra_bin
KF5::CoreAddons
KF5::ItemModels
KF5::Crash
Qt::Network
Qt::PrintSupport # Printing secret keys
Qt5::Network
Qt5::PrintSupport # Printing secret keys
${_kleopatra_uiserver_extra_libs}
${_kleopatra_dbusaddons_libs}
kleopatraclientcore
......
......@@ -64,6 +64,6 @@ else()
endif()
endif()
target_link_libraries(kleopatraclientcore Qt::Widgets KF5::I18n Gpgmepp)
target_link_libraries(kleopatraclientcore Qt5::Widgets KF5::I18n Gpgmepp)
install(TARGETS kleopatraclientcore ${KDE_INSTALL_TARGETS_DEFAULT_ARGS})
......@@ -11,7 +11,7 @@ foreach(_kleoclient_test ${kleoclient_TESTS})
target_link_libraries("${_kleoclient_test}"
kleopatraclientcore
Qt::Gui
Qt::Core
Qt5::Gui
Qt5::Core
)
endforeach()
......@@ -22,11 +22,11 @@ ecm_mark_as_test(test_verify)
target_link_libraries(test_verify
KF5::Libkleo
Qt::Test
Qt5::Test
QGpgme
KF5::CoreAddons
KF5::I18n
Qt::Widgets
Qt5::Widgets
)
########### next target ###############
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment