Commit 8f11cb94 authored by Laurent Montel's avatar Laurent Montel
Browse files

Adapt to new api

parent 844505a2
Pipeline #219887 passed with stage
in 9 minutes
......@@ -71,7 +71,7 @@ set(LIBGRAVATAR_VERSION "5.21.40")
set(MAILCOMMON_LIB_VERSION "5.21.41")
set(MESSAGELIB_LIB_VERSION "5.21.42")
set(LIBKLEO_LIB_VERSION "5.21.40")
set(PIMCOMMON_LIB_VERSION "5.21.40")
set(PIMCOMMON_LIB_VERSION "5.21.41")
set(LIBKDEPIM_LIB_VERSION "5.21.40")
set(LIBKSIEVE_LIB_VERSION "5.21.40")
set(AKONADI_SEARCH_VERSION "5.21.40")
......
......@@ -28,11 +28,11 @@ void KMailPluginInterface::setMainWidget(KMMainWidget *mainwindow)
mMainWindow = mainwindow;
}
void KMailPluginInterface::initializeInterfaceRequires(PimCommon::AbstractGenericPluginInterface *abstractInterface)
bool KMailPluginInterface::initializeInterfaceRequires(PimCommon::AbstractGenericPluginInterface *abstractInterface)
{
if (!mMainWindow) {
qCCritical(KMAIL_LOG) << "mainwindows not defined";
return;
return false;
}
auto interface = static_cast<PimCommon::GenericPluginInterface *>(abstractInterface);
const PimCommon::GenericPluginInterface::RequireTypes requiresFeatures = interface->requiresFeatures();
......@@ -52,4 +52,5 @@ void KMailPluginInterface::initializeInterfaceRequires(PimCommon::AbstractGeneri
if (requiresFeatures & PimCommon::GenericPluginInterface::Collections) {
qCDebug(KMAIL_LOG) << "PimCommon::GenericPluginInterface::Collection not implemented";
}
return true;
}
......@@ -17,7 +17,7 @@ public:
~KMailPluginInterface() override;
void setMainWidget(KMMainWidget *mainwindow);
void initializeInterfaceRequires(PimCommon::AbstractGenericPluginInterface *interface) override;
bool initializeInterfaceRequires(PimCommon::AbstractGenericPluginInterface *interface) override;
static KMailPluginInterface *self();
private:
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment