Commit ec368279 authored by Laurent Montel's avatar Laurent Montel 😁
Browse files

GIT_SILENT: time to increase version

parent 49f684c9
Pipeline #74805 canceled with stage
......@@ -3,13 +3,14 @@ set(PIM_VERSION "5.18.40")
project(MailTransport VERSION ${PIM_VERSION})
# ECM setup
set(KF5_MIN_VERSION "5.84.0")
set(KF5_MIN_VERSION "5.85.0")
find_package(ECM ${KF5_MIN_VERSION} CONFIG REQUIRED)
set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH})
include(KDEInstallDirs)
include(KDECMakeSettings)
set(KDE_COMPILERSETTINGS_LEVEL 5.85.0)
include(KDEFrameworkCompilerSettings NO_POLICY_SCOPE)
include(GenerateExportHeader)
......@@ -56,7 +57,7 @@ set_package_properties(Qt5Keychain PROPERTIES
option(KDEPIM_RUN_AKONADI_TEST "Enable autotest based on Akonadi." ON)
add_definitions(-DQT_DISABLE_DEPRECATED_BEFORE=0x050f00)
add_definitions(-DKF_DISABLE_DEPRECATED_BEFORE_AND_AT=0x055500)
add_definitions(-DKF_DISABLE_DEPRECATED_BEFORE_AND_AT=0x055600)
set(CMAKE_CXX_STANDARD 17)
set(CMAKE_CXX_STANDARD_REQUIRED ON)
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment