Commit 04fc6d13 authored by Nicolas Fella's avatar Nicolas Fella
Browse files

Make dependency on KI18n explicit

It already pulled in by KParts, but we better not rely on that
parent 331d0d21
Pipeline #59906 passed with stage
in 3 minutes and 44 seconds
......@@ -51,6 +51,7 @@ find_package(Qt5 ${QT_REQUIRED_VERSION} CONFIG REQUIRED DBus Widgets WebEngine W
set(LIBKDEPIM_LIB_VERSION "5.17.40")
set(LIBGRANTLEETHEME_LIB_VERSION "5.17.40")
# Find KF5 package
find_package(KF5I18n ${KF5_MIN_VERSION} CONFIG REQUIRED)
find_package(KF5DBusAddons ${KF5_MIN_VERSION} CONFIG REQUIRED)
find_package(KF5KCMUtils ${KF5_MIN_VERSION} CONFIG REQUIRED)
find_package(KF5Crash ${KF5_MIN_VERSION} REQUIRED)
......
......@@ -38,6 +38,7 @@ target_link_libraries(kontactprivate
KF5::WindowSystem
KF5::IconThemes
PRIVATE
KF5::I18n
KF5::KIOWidgets
KF5::KontactInterface
KF5::KCMUtils
......@@ -68,6 +69,7 @@ set_target_properties(kontact_bin PROPERTIES OUTPUT_NAME kontact)
target_link_libraries(kontact_bin
kontactprivate
KF5::I18n
KF5::KontactInterface
KF5::Crash
)
......@@ -84,6 +86,7 @@ set(kcm_kontact_PART_SRCS kcmkontact.cpp)
add_library(kcm_kontact MODULE ${kcm_kontact_PART_SRCS})
target_link_libraries(kcm_kontact
KF5::I18n
KF5::KCMUtils
KF5::Libkdepim
kontactprivate
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment