Members of the KDE Community are recommended to subscribe to the kde-community mailing list at https://mail.kde.org/mailman/listinfo/kde-community to allow them to participate in important discussions and receive other important announcements

Commit c2b8709c authored by Laurent Montel's avatar Laurent Montel 😁

Fix check

parent f57f36f5
......@@ -5,8 +5,12 @@ find_dependency(KF5Parts "@KF5_VERSION@")
if(NOT CMAKE_VERSION VERSION_LESS "3.10.0")
# CMake 3.9+ warns about automoc on files without Q_OBJECT, and doesn't know about other macros.
# 3.10+ lets us provide more macro names that require automoc.
# Remove this when depending on a Frameworks or ECM version that solves this upstream.
list(APPEND CMAKE_AUTOMOC_MACRO_NAMES "K_PLUGIN_FACTORY_WITH_JSON" "K_PLUGIN_FACTORY" "EXPORT_KONTACT_PLUGIN")
# KF5 >= 5.42 takes care itself of adding its macros in its cmake config files
if (KF5_VERSION VERSION_LESS "5.42.0")
list(APPEND CMAKE_AUTOMOC_MACRO_NAMES "K_PLUGIN_FACTORY_WITH_JSON" "K_PLUGIN_FACTORY" "EXPORT_KONTACT_PLUGIN")
else()
list(APPEND CMAKE_AUTOMOC_MACRO_NAMES "EXPORT_KONTACT_PLUGIN")
endif()
endif()
include("${CMAKE_CURRENT_LIST_DIR}/KF5KontactInterfaceTargets.cmake")
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment