Commit 92075545 authored by Ingo Klöcker's avatar Ingo Klöcker
Browse files

[q]gpgme[++] has been released as version 1.16.0

parent 477d9946
Pipeline #67482 passed with stage
in 7 minutes and 16 seconds
......@@ -45,7 +45,7 @@ find_package(Gpgmepp ${GPGMEPP_LIB_VERSION} CONFIG REQUIRED)
set_package_properties(Gpgmepp PROPERTIES DESCRIPTION "GpgME++ Library" URL "https://www.gnupg.org" TYPE REQUIRED PURPOSE "GpgME++ is required for OpenPGP support")
find_package(QGpgme ${GPGMEPP_LIB_VERSION} CONFIG REQUIRED)
message(STATUS "GPGME Version ${Gpgmepp_VERSION}")
if (Gpgmepp_VERSION VERSION_GREATER_EQUAL "1.15.2")
if (Gpgmepp_VERSION VERSION_GREATER_EQUAL "1.16.0")
set(GPGMEPP_SUPPORTS_TRUST_SIGNATURES 1)
endif()
......
......@@ -332,7 +332,7 @@ int main(int argc, char **argv)
Q_ASSERT(lst[1].query() == QStringLiteral("a:b c")); // see, the space got _not_escaped
lst << QUrl(QStringLiteral("ldap://server:389?a=b,c=DE"));
Q_ASSERT(lst[2].query() == QStringLiteral("a=b,c=DE")); // the query contains a literal ','
#if GPGMEPP_VERSION >= 0x10F02 // 1.15.2
#if GPGMEPP_VERSION >= 0x11000 // 1.16.0
lst << QUrl(QStringLiteral("ldap://foo:389?a#ldaps"));
Q_ASSERT(lst[3].fragment() == QStringLiteral("ldaps"));
#endif
......@@ -363,7 +363,7 @@ int main(int argc, char **argv)
Q_ASSERT(newlst[0].url() == lst[0].url());
Q_ASSERT(newlst[1].url() == lst[1].url());
Q_ASSERT(newlst[2].url() == lst[2].url());
#if GPGMEPP_VERSION >= 0x10F02 // 1.15.2
#if GPGMEPP_VERSION >= 0x11000 // 1.16.0
Q_ASSERT(newlst[3].url() == lst[3].url());
#endif
......
......@@ -904,7 +904,7 @@ void prepareURLCfgDialog(QDialog *dialog, DirectoryServicesWidget *dirserv, bool
void Kleo::CryptoConfigEntryLDAPURL::slotOpenDialog()
{
if (!gpgme_check_version("1.15.2")) {
if (!gpgme_check_version("1.16.0")) {
KMessageBox::sorry(mPushButton->parentWidget(),
i18n("Configuration of directory services is not possible "
"because the used gpgme libraries are too old."),
......
......@@ -13,7 +13,7 @@
#include <QGpgME/CryptoConfig>
#include <gpgme++/gpgmepp_version.h>
#if GPGMEPP_VERSION >= 0x10F02 // 1.15.2
#if GPGMEPP_VERSION >= 0x11000 // 1.16.0
# define CRYPTOCONFIG_HAS_GROUPLESS_ENTRY_OVERLOAD
#endif
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment