Commit a2206332 authored by Laurent Montel's avatar Laurent Montel 😁
Browse files

GIT_SILENT: use c++17 as in the future we will depend against ecm which depend on it

parent 9fa4cb24
Pipeline #57208 skipped
...@@ -68,7 +68,7 @@ add_definitions(-DKF_DISABLE_DEPRECATED_BEFORE_AND_AT=0x055200) ...@@ -68,7 +68,7 @@ add_definitions(-DKF_DISABLE_DEPRECATED_BEFORE_AND_AT=0x055200)
remove_definitions(-DQT_NO_CAST_FROM_ASCII ) remove_definitions(-DQT_NO_CAST_FROM_ASCII )
remove_definitions(-DQT_NO_FOREACH) remove_definitions(-DQT_NO_FOREACH)
add_definitions(-DQT_NO_EMIT) add_definitions(-DQT_NO_EMIT)
set(CMAKE_CXX_STANDARD 14) set(CMAKE_CXX_STANDARD 17)
set(CMAKE_CXX_STANDARD_REQUIRED ON) set(CMAKE_CXX_STANDARD_REQUIRED ON)
########### CMake Config Files ########### ########### CMake Config Files ###########
set(CMAKECONFIG_INSTALL_DIR "${KDE_INSTALL_CMAKEPACKAGEDIR}/KF5Libkleo") set(CMAKECONFIG_INSTALL_DIR "${KDE_INSTALL_CMAKEPACKAGEDIR}/KF5Libkleo")
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment