Lower min KF5 Version for Windows

To develop for Windows we often compile libkleo and kleopatra
with older kde frameworks. The Gpg4win build system patched
that but it is better to have it in the repo itself.

The release scripts that bump the dependencies in general
should still work.
2 jobs for master
Status Job ID Name Coverage
  Build
canceled #76151
build_clazy_clang_tidy

canceled #76150
linux kf5-qt5 qt5.12