Commit d5762ccb authored by Laurent Montel's avatar Laurent Montel 😁

GIT_SILENT: Prepare 5.14.0 beta1.

parent fac5b143
......@@ -30,13 +30,13 @@ include(ECMAddTests)
set(LIBKSIEVE_LIB_VERSION ${PIM_VERSION})
set(QT_REQUIRED_VERSION "5.12.0")
set(KMIME_LIB_VERSION "5.13.40")
set(IDENTITYMANAGEMENT_LIB_VERSION "5.13.40")
set(KMAILTRANSPORT_LIB_VERSION "5.13.40")
set(KPIMTEXTEDIT_LIB_VERSION "5.13.40")
set(LIBKDEPIM_LIB_VERSION "5.13.40")
set(PIMCOMMON_LIB_VERSION "5.13.40")
set(KIMAP_LIB_VERSION "5.13.40")
set(KMIME_LIB_VERSION "5.13.80")
set(IDENTITYMANAGEMENT_LIB_VERSION "5.13.80")
set(KMAILTRANSPORT_LIB_VERSION "5.13.80")
set(KPIMTEXTEDIT_LIB_VERSION "5.13.80")
set(LIBKDEPIM_LIB_VERSION "5.13.80")
set(PIMCOMMON_LIB_VERSION "5.13.80")
set(KIMAP_LIB_VERSION "5.13.80")
option(KDEPIM_ENTERPRISE_BUILD "Enable features specific to the enterprise branch, which are normally disabled. Also, it disables many components not needed for Kontact such as the Kolab client." FALSE)
set(CMAKE_CXX_STANDARD 14)
......@@ -72,7 +72,7 @@ ecm_setup_version(PROJECT VARIABLE_PREFIX LIBKSIEVE
if (EXISTS "${CMAKE_SOURCE_DIR}/.git")
add_definitions(-DQT_DISABLE_DEPRECATED_BEFORE=0x050e00)
add_definitions(-DKF_DISABLE_DEPRECATED_BEFORE_AND_AT=0x058000)
add_definitions(-DKF_DISABLE_DEPRECATED_BEFORE_AND_AT=0x054400)
endif()
add_definitions(-DQT_NO_FOREACH)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment