Commit 783b950d authored by Laurent Montel's avatar Laurent Montel 😁
Browse files

GIT_SILENT: increase cmake version

parent ef67b40e
cmake_minimum_required(VERSION 3.0)
set(PIM_VERSION "5.4.40")
cmake_minimum_required(VERSION 2.8.12)
project(MailImporter)
project(MailImporter VERSION ${PIM_VERSION})
set(KF5_VERSION "5.28.0")
find_package(ECM ${KF5_VERSION} CONFIG REQUIRED)
......@@ -22,7 +22,6 @@ include(ECMAddTests)
include(ECMCoverageOption)
set(PIM_VERSION "5.4.40")
set(MAILIMPORTER_LIB ${PIM_VERSION})
......@@ -44,7 +43,7 @@ find_package(KF5Mime ${KMIME_LIB_VERSION} CONFIG REQUIRED)
find_package(KF5AkonadiMime ${AKONADIMIME_LIB_VERSION} CONFIG REQUIRED)
find_package(KF5Libkdepim ${KDEPIM_LIB_VERSION} CONFIG REQUIRED)
ecm_setup_version(${MAILIMPORTER_LIB} VARIABLE_PREFIX MAILIMPORTER
ecm_setup_version(PROJECT VARIABLE_PREFIX MAILIMPORTER
VERSION_HEADER "${CMAKE_CURRENT_BINARY_DIR}/mailimporter_version.h"
PACKAGE_VERSION_FILE "${CMAKE_CURRENT_BINARY_DIR}/KF5MailImporterConfigVersion.cmake"
SOVERSION 5
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment