Commit 8aad5e73 authored by Laurent Montel's avatar Laurent Montel 😁
Browse files

GIT_SILENT: Prepare 5.14.0 beta1. Update ecm as 5.67.0 is broken see 417396....

GIT_SILENT: Prepare 5.14.0 beta1. Update ecm as 5.67.0 is broken see 417396. 5.68 will be release in 2 days. But dependancy freeze is tomorrow.
parent d20f26ff
cmake_minimum_required(VERSION 3.5)
set(PIM_VERSION "5.13.40")
set(PIM_VERSION "5.13.80")
project(MailImporter VERSION ${PIM_VERSION})
set(KF5_MIN_VERSION "5.67.0")
set(KF5_MIN_VERSION "5.68.0")
find_package(ECM ${KF5_MIN_VERSION} CONFIG REQUIRED)
set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH})
......@@ -66,14 +66,10 @@ add_definitions(-DQT_NO_FOREACH)
add_subdirectory(src)
if (ECM_VERSION VERSION_LESS "5.68.0")
install(FILES mailimporter.renamecategories mailimporter.categories DESTINATION ${KDE_INSTALL_LOGGINGCATEGORIESDIR})
else ()
ecm_qt_install_logging_categories(
ecm_qt_install_logging_categories(
EXPORT MAILIMPORTER
FILE mailimporter.categories
DESTINATION ${KDE_INSTALL_LOGGINGCATEGORIESDIR}
)
endif()
feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)
org.kde.pim.mailimporter mailimporter (mailimporter) IDENTIFIER [MAILIMPORTER_LOG]
org.kde.pim.mailimporterakonadi mailimporterakonadi (mailimporter) IDENTIFIER [MAILIMPORTERAKONADI_LOG]
log_mailimporter org.kde.pim.mailimporter
......@@ -65,15 +65,11 @@ set(libmailimporter_SRCS
ki18n_wrap_ui(libmailimporter_SRCS ui/importmailswidget.ui ui/selectthunderbirdprofilewidget.ui)
if (ECM_VERSION VERSION_LESS "5.68.0")
ecm_qt_declare_logging_category(libmailimporter_SRCS HEADER mailimporter_debug.h IDENTIFIER MAILIMPORTER_LOG CATEGORY_NAME org.kde.pim.mailimporter)
else()
ecm_qt_declare_logging_category(libmailimporter_SRCS HEADER mailimporter_debug.h IDENTIFIER MAILIMPORTER_LOG CATEGORY_NAME org.kde.pim.mailimporter
ecm_qt_declare_logging_category(libmailimporter_SRCS HEADER mailimporter_debug.h IDENTIFIER MAILIMPORTER_LOG CATEGORY_NAME org.kde.pim.mailimporter
DESCRIPTION "mailimporter (mailimporter)"
OLD_CATEGORY_NAMES log_mailimporter
EXPORT MAILIMPORTER
)
endif()
add_library(KF5MailImporter
${libmailimporter_SRCS}
......
......@@ -31,14 +31,10 @@ set(libmailimporterakonadi_SRCS
filterimporterakonadi.cpp
)
if (ECM_VERSION VERSION_LESS "5.68.0")
ecm_qt_declare_logging_category(libmailimporterakonadi_SRCS HEADER mailimporterakonadi_debug.h IDENTIFIER MAILIMPORTERAKONADI_LOG CATEGORY_NAME org.kde.pim.mailimporterakonadi)
else()
ecm_qt_declare_logging_category(libmailimporterakonadi_SRCS HEADER mailimporterakonadi_debug.h IDENTIFIER MAILIMPORTERAKONADI_LOG CATEGORY_NAME org.kde.pim.mailimporterakonadi
ecm_qt_declare_logging_category(libmailimporterakonadi_SRCS HEADER mailimporterakonadi_debug.h IDENTIFIER MAILIMPORTERAKONADI_LOG CATEGORY_NAME org.kde.pim.mailimporterakonadi
DESCRIPTION "mailimporterakonadi (mailimporter)"
EXPORT MAILIMPORTER
)
endif()
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment