Commit d5b8b288 authored by Laurent Montel's avatar Laurent Montel 😁
Browse files

Use PimCommon class directly

parent 05767851
Pipeline #23249 passed with stage
in 9 minutes and 12 seconds
...@@ -28,10 +28,10 @@ set(MAILIMPORTER_LIB ${PIM_VERSION}) ...@@ -28,10 +28,10 @@ set(MAILIMPORTER_LIB ${PIM_VERSION})
set(AKONADIMIME_LIB_VERSION "5.14.40") set(AKONADIMIME_LIB_VERSION "5.14.40")
set(KDEPIM_LIB_VERSION "5.14.40")
set(QT_REQUIRED_VERSION "5.13.0") set(QT_REQUIRED_VERSION "5.13.0")
set(KMIME_LIB_VERSION "5.14.40") set(KMIME_LIB_VERSION "5.14.40")
set(AKONADI_VERSION "5.14.40") set(AKONADI_VERSION "5.14.40")
set(PIMCOMMON_LIB_VERSION_LIB "5.14.42")
find_package(Qt5 ${QT_REQUIRED_VERSION} CONFIG REQUIRED Widgets Test Xml) find_package(Qt5 ${QT_REQUIRED_VERSION} CONFIG REQUIRED Widgets Test Xml)
...@@ -43,8 +43,7 @@ find_package(KF5I18n ${KF5_MIN_VERSION} CONFIG REQUIRED) ...@@ -43,8 +43,7 @@ find_package(KF5I18n ${KF5_MIN_VERSION} CONFIG REQUIRED)
find_package(KF5Akonadi ${AKONADI_VERSION} CONFIG REQUIRED) find_package(KF5Akonadi ${AKONADI_VERSION} CONFIG REQUIRED)
find_package(KF5Mime ${KMIME_LIB_VERSION} CONFIG REQUIRED) find_package(KF5Mime ${KMIME_LIB_VERSION} CONFIG REQUIRED)
find_package(KF5AkonadiMime ${AKONADIMIME_LIB_VERSION} CONFIG REQUIRED) find_package(KF5AkonadiMime ${AKONADIMIME_LIB_VERSION} CONFIG REQUIRED)
find_package(KF5Libkdepim ${KDEPIM_LIB_VERSION} CONFIG REQUIRED) find_package(KF5PimCommonAkonadi ${PIMCOMMON_LIB_VERSION_LIB} CONFIG REQUIRED)
########### Targets ########### ########### Targets ###########
......
...@@ -88,7 +88,7 @@ target_link_libraries(KF5MailImporter ...@@ -88,7 +88,7 @@ target_link_libraries(KF5MailImporter
PUBLIC PUBLIC
KF5::Archive KF5::Archive
PRIVATE PRIVATE
KF5::Libkdepim KF5::PimCommon
KF5::I18n KF5::I18n
KF5::ConfigCore KF5::ConfigCore
Qt5::Xml Qt5::Xml
......
...@@ -131,7 +131,7 @@ ...@@ -131,7 +131,7 @@
</layout> </layout>
</item> </item>
<item> <item>
<widget class="KPIM::CustomLogWidget" name="log" native="true"/> <widget class="PimCommon::CustomLogWidget" name="log" native="true"/>
</item> </item>
</layout> </layout>
</item> </item>
...@@ -139,9 +139,9 @@ ...@@ -139,9 +139,9 @@
</widget> </widget>
<customwidgets> <customwidgets>
<customwidget> <customwidget>
<class>KPIM::CustomLogWidget</class> <class>PimCommon::CustomLogWidget</class>
<extends>QWidget</extends> <extends>QWidget</extends>
<header location="global">Libkdepim/CustomLogWidget</header> <header location="global">PimCommon/CustomLogWidget</header>
<container>1</container> <container>1</container>
</customwidget> </customwidget>
</customwidgets> </customwidgets>
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment