Commit 512ab723 authored by Laurent Montel's avatar Laurent Montel 😁
Browse files

We need KF5::I18n now

parent 54806b81
......@@ -74,6 +74,8 @@ target_link_libraries(KF5MessageList
KF5::XmlGui
KF5::IconThemes
KF5::Completion
KF5::I18n
KF5::TextWidgets
)
set_target_properties(KF5MessageList PROPERTIES
......
......@@ -20,7 +20,7 @@ macro(add_messageviewer_class_unittest _source _additionalSource)
ecm_add_test(${_source} ${_additionalSource}
TEST_NAME ${_name}
NAME_PREFIX "messageviewer-"
LINK_LIBRARIES KF5::MessageViewer Qt5::Test KF5::IconThemes KF5::XmlGui Qt5::WebKitWidgets
LINK_LIBRARIES KF5::MessageViewer Qt5::Test KF5::IconThemes KF5::XmlGui Qt5::WebKitWidgets KF5::I18n
)
endmacro ()
......
......@@ -3,6 +3,7 @@ add_executable(adblocksettings_gui ${adblocksettings_gui_SRCS})
target_link_libraries(adblocksettings_gui
KF5::MessageViewer
KF5::ItemViews
KF5::I18n
)
set(adblocksettingsdialog_gui_SRCS adblocksettingsdialog_gui.cpp)
......@@ -10,6 +11,7 @@ add_executable(adblocksettingsdialog_gui ${adblocksettingsdialog_gui_SRCS})
target_link_libraries(adblocksettingsdialog_gui
KF5::MessageViewer
KF5::ItemViews
KF5::I18n
)
if (NOT MESSAGEVIEWER_USE_QTWEBENGINE)
set(adblockblockableitemdialog_gui_SRCS adblockblockableitemdialog_gui.cpp)
......@@ -20,6 +22,7 @@ if (NOT MESSAGEVIEWER_USE_QTWEBENGINE)
KF5::Libkdepim
Qt5::WebKitWidgets
KF5::ItemViews
KF5::I18n
)
endif()
......@@ -28,4 +31,5 @@ add_executable(adblockautomaticruleslistwidget_gui ${adblockautomaticruleslistwi
target_link_libraries(adblockautomaticruleslistwidget_gui
KF5::MessageViewer
KF5::ItemViews
KF5::I18n
)
......@@ -11,6 +11,7 @@ if (NOT MESSAGEVIEWER_USE_QTWEBENGINE)
KF5::KIOCore
KF5::MessageViewer
Qt5::WebKitWidgets
KF5::I18n
)
endif()
......@@ -24,6 +25,7 @@ if (QTWEBENGINE_SUPPORT_OPTION)
KF5::MessageViewer
Qt5::WebEngine
Qt5::WebEngineWidgets
KF5::I18n
)
endif()
......@@ -3,5 +3,6 @@ add_executable(viewerplugin_gui ${viewerplugin_gui_SRCS})
target_link_libraries(viewerplugin_gui
KF5::MessageViewer
KF5::XmlGui
KF5::I18n
)
......@@ -8,5 +8,6 @@ target_link_libraries(viewertest_gui
KF5::Mime
KF5::MessageViewer
KF5::GrantleeTheme
KF5::I18n
)
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment