Commit a779a6e8 authored by Laurent Montel's avatar Laurent Montel 😁
Browse files

Prepare the future (we will depend against qt >= 5.6.0)

parent 87abee15
......@@ -23,7 +23,7 @@ set(MESSAGELIB_LIB_VERSION "5.2.56")
set(KF5_VERSION "5.19.0")
set(KDEPIMLIBS_LIB_VERSION "5.2.40")
set(QT_REQUIRED_VERSION "5.4.0")
set(QT_REQUIRED_VERSION "5.6.0")
set(KMIME_LIB_VERSION "5.2.40")
set(KLDAP_LIB_VERSION "5.2.40")
set(KPIMTEXTEDIT_LIB_VERSION "5.2.40")
......@@ -85,8 +85,7 @@ option(QTWEBENGINE_SUPPORT_OPTION "Enable support for QtWebEngine. False by defa
option(MESSAGEVIEWER_USE_QTWEBENGINE "Use QtWebEngine in mail viewer. False by default." FALSE)
if (QTWEBENGINE_SUPPORT_OPTION)
set(QT_REQUIRED_MINIMUM_WEBENGINE_VERSION "5.6")
find_package(Qt5 ${QT_REQUIRED_MINIMUM_WEBENGINE_VERSION} CONFIG REQUIRED WebEngine WebEngineWidgets)
find_package(Qt5 ${QT_REQUIRED_VERSION} CONFIG REQUIRED WebEngine WebEngineWidgets)
endif()
if (MESSAGEVIEWER_USE_QTWEBENGINE AND NOT QTWEBENGINE_SUPPORT_OPTION)
......
@PACKAGE_INIT@
find_dependency(Qt5WebEngine "@QT_REQUIRED_MINIMUM_WEBENGINE_VERSION@")
find_dependency(Qt5WebEngine "@QT_REQUIRED_VERSION@")
include("${CMAKE_CURRENT_LIST_DIR}/KF5WebEngineViewerTargets.cmake")
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment