Commit ea0cab95 authored by Laurent Montel's avatar Laurent Montel 😁

Add info when we try to load a plugin which doesn't have correct version

parent f03f96ef
......@@ -23,6 +23,7 @@
#include <KPluginFactory>
#include <QFileInfo>
#include <QSet>
#include <QDebug>
using namespace MessageViewer;
......@@ -122,6 +123,8 @@ bool ViewerPluginManagerPrivate::initializePluginList()
info.plugin = Q_NULLPTR;
mPluginList.push_back(info);
unique.insert(info.saveName());
} else {
qWarning() << "Plugin name :" << info.metaData.name() << " doesn't have correct plugin version. Please update it";
}
}
QVector<ViewerPluginInfo>::iterator end(mPluginList.end());
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment