Decrease QCA dependency to 2.2.0

Builds fine and currently we don't have 2.3.0 on Windows
2 jobs for master
Status Job ID Name Coverage
  Build
canceled #76159
build_clazy_clang_tidy

canceled #76158
linux kf5-qt5 qt5.12