Commit a955dd92 authored by Laurent Montel's avatar Laurent Montel 😁

Add warning about plugin version

parent 9e372854
......@@ -108,6 +108,8 @@ bool PluginEditorManagerPrivate::initializePlugins()
info.plugin = Q_NULLPTR;
mPluginList.push_back(info);
unique.insert(info.saveName());
} else {
qWarning() << "Plugin " << info.metaData.name() << " doesn't have correction plugin version. It will not be loaded.";
}
}
QVector<PluginEditorInfo>::iterator end(mPluginList.end());
......
......@@ -22,6 +22,7 @@
#include <kpluginmetadata.h>
#include <QFileInfo>
#include <QSet>
#include <QDebug>
using namespace MessageViewer;
......@@ -123,6 +124,8 @@ void HeaderStylePluginManagerPrivate::initializePluginList()
info.plugin = Q_NULLPTR;
mPluginList.insert(pos, info);
unique.insert(info.saveName());
} else {
qWarning() << "Plugin " << info.metaData.name() << " doesn't have correction plugin version. It will not be loaded.";
}
}
QVector<HeaderStylePluginInfo>::iterator end(mPluginList.end());
......
......@@ -23,6 +23,7 @@
#include <QFileInfo>
#include <QVariant>
#include <QSet>
#include <QDebug>
#include <kpluginmetadata.h>
using namespace MessageViewer;
......@@ -112,6 +113,8 @@ void NetworkUrlInterceptorPluginManagerPrivate::initializePluginList()
info.plugin = Q_NULLPTR;
mPluginList.append(info);
unique.insert(info.saveName());
} else {
qWarning() << "Plugin " << info.metaData.name() << " doesn't have correction plugin version. It will not be loaded.";
}
}
QVector<MailNetworkUrlInterceptorPluginInfo>::iterator end(mPluginList.end());
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment