Commit eca91edd authored by Laurent Montel's avatar Laurent Montel 😁

Add more Q_FALLTHROUGH

parent df20b98f
......@@ -1914,6 +1914,9 @@ bool ComposerViewBase::determineWhetherToEncrypt(bool doEncryptCompletely, Kleo:
case Kleo::AskOpportunistic:
opportunistic = true;
// fall through...
#if QT_VERSION >= QT_VERSION_CHECK(5,8,0)
Q_FALLTHROUGH();
#endif
case Kleo::Ask: {
// the user wants to be asked or has to be asked
#ifndef QT_NO_CURSOR
......
......@@ -161,6 +161,9 @@ void MessageComposer::Util::makeToplevelContentType(KMime::Content *content, Kle
// fall through (for encryption, there's no difference between
// SMIME and SMIMEOpaque, since there is no mp/encrypted for
// S/MIME)
#if QT_VERSION >= QT_VERSION_CHECK(5,8,0)
Q_FALLTHROUGH();
#endif
case Kleo::SMIMEOpaqueFormat:
qCDebug(MESSAGECOMPOSER_LOG) << "setting headers for SMIME/opaque";
......@@ -193,6 +196,9 @@ void MessageComposer::Util::setNestedContentType(KMime::Content *content, Kleo::
content->contentType()->setParameter(QStringLiteral("name"), QString::fromAscii("smime.p7s"));
return;
}
#if QT_VERSION >= QT_VERSION_CHECK(5,8,0)
Q_FALLTHROUGH();
#endif
// fall through:
default:
case Kleo::InlineOpenPGPFormat:
......
......@@ -723,6 +723,9 @@ void ThemeDelegate::paint(QPainter *painter, const QStyleOptionViewItem &option,
);
}
// fall through anyway
#if QT_VERSION >= QT_VERSION_CHECK(5,8,0)
Q_FALLTHROUGH();
#endif
}
case Theme::RoundedRect: {
painter->setPen(Qt::NoPen);
......@@ -768,6 +771,9 @@ void ThemeDelegate::paint(QPainter *painter, const QStyleOptionViewItem &option,
);
}
// fall through anyway
#if QT_VERSION >= QT_VERSION_CHECK(5,8,0)
Q_FALLTHROUGH();
#endif
}
case Theme::GradientRect: {
// FIXME: Could cache this brush
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment