Commit d98d9c49 authored by Laurent Montel's avatar Laurent Montel 😁

GIT_SILENT: prepare 5.16.0

parent c33145c3
Pipeline #43634 passed with stage
in 9 minutes and 36 seconds
...@@ -27,15 +27,15 @@ set(CMAKE_CXX_STANDARD 14) ...@@ -27,15 +27,15 @@ set(CMAKE_CXX_STANDARD 14)
set(CMAKE_CXX_STANDARD_REQUIRED ON) set(CMAKE_CXX_STANDARD_REQUIRED ON)
set(PIMCOMMON_LIB_VERSION ${PIM_VERSION}) set(PIMCOMMON_LIB_VERSION ${PIM_VERSION})
set(AKONADICONTACT_LIB_VERSION "5.15.90") set(AKONADICONTACT_LIB_VERSION "5.16.0")
set(LIBKDEPIM_LIB_VERSION "5.15.90") set(LIBKDEPIM_LIB_VERSION "5.16.0")
set(QT_REQUIRED_VERSION "5.13.0") set(QT_REQUIRED_VERSION "5.13.0")
set(KMIME_LIB_VERSION "5.15.90") set(KMIME_LIB_VERSION "5.16.0")
set(KIMAP_LIB_VERSION "5.15.90") set(KIMAP_LIB_VERSION "5.16.0")
set(KPIMTEXTEDIT_LIB_VERSION "5.15.90") set(KPIMTEXTEDIT_LIB_VERSION "5.16.0")
set(AKONADI_VERSION "5.15.90") set(AKONADI_VERSION "5.16.0")
set(KLDAP_LIB_VERSION "5.15.90") set(KLDAP_LIB_VERSION "5.16.0")
set(GRANTLEETHEME_LIB_VERSION "5.15.90") set(GRANTLEETHEME_LIB_VERSION "5.16.0")
find_package(Qt5 ${QT_REQUIRED_VERSION} CONFIG REQUIRED Widgets DBus Network Test Xml PrintSupport) find_package(Qt5 ${QT_REQUIRED_VERSION} CONFIG REQUIRED Widgets DBus Network Test Xml PrintSupport)
...@@ -71,7 +71,7 @@ add_feature_info(DESIGNERPLUGIN ${BUILD_DESIGNERPLUGIN} "Build plugin for Qt Des ...@@ -71,7 +71,7 @@ add_feature_info(DESIGNERPLUGIN ${BUILD_DESIGNERPLUGIN} "Build plugin for Qt Des
option(FORCE_DISABLE_AKONADI_SEARCH "Disable features and API that require akonadi-search, e.g. because xapian isn't available" OFF) option(FORCE_DISABLE_AKONADI_SEARCH "Disable features and API that require akonadi-search, e.g. because xapian isn't available" OFF)
if (NOT FORCE_DISABLE_AKONADI_SEARCH) if (NOT FORCE_DISABLE_AKONADI_SEARCH)
set(AKONADI_SEARCH_VERSION "5.15.90") set(AKONADI_SEARCH_VERSION "5.16.0")
find_package(KF5AkonadiSearch ${AKONADI_SEARCH_VERSION} CONFIG REQUIRED) find_package(KF5AkonadiSearch ${AKONADI_SEARCH_VERSION} CONFIG REQUIRED)
set_package_properties(KF5AkonadiSearch PROPERTIES DESCRIPTION "The Akonadi Search libraries" URL "https://www.kde.org" TYPE REQUIRED PURPOSE "Provides search capabilities in KMail and Akonadi") set_package_properties(KF5AkonadiSearch PROPERTIES DESCRIPTION "The Akonadi Search libraries" URL "https://www.kde.org" TYPE REQUIRED PURPOSE "Provides search capabilities in KMail and Akonadi")
endif() endif()
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment